Getting clients to show up

So here is my setup. I have a Raspberry Pi3 b+ setup with Ubuntu on it, which has docker installed. I then use that as an app server that runs a few containers; Home Assistant, Pi Hole, MQTT Broker, etc).

My Pi Hole container works great and I have my router pointed to use the app server’s IP pi hole, pi hole uses it with a handful of ports passed to the container. If I go to my app server IP. Let’s say 192.168.86.20 I can get to pi hole see the graphs, the blocked content etc. However, It only shows my router as connected (it also shows the app server “localhost”). But all of my computers, TV, smart devices don’t show. they are being considered as part of my router.

I use a Google OnHub (TP-Link version), You assume it would pass its local domain list to the pi hole so you could see what is making the request.

There as to be some way without altering each devices network settings to point to pi hole.

Any thoughts

This is typically done in one of two ways.

  1. Use the conditional forwarding option in Pi-Hole (admin GUI > settings > DNS).
  2. Use Pi-Hole as the DHCP server.

When I use condition forwarding I add my routers IP and for “local domain name” I use “lan” because I can’t seem to change that setting on my OnHub. When I do this I will get the name of a client but only rather than just its IP. However I still need to go into that device’s settings and point it to the pi-hole.

For example my desktop, if I manually assign a DNS (the pi-hole) and use forwarding in pi-hole then I get a name for my desktop. I was hoping for a way for the OnHub to pass the client along with the query so I can see all the devices on the OnHub making requests through the pi-hole.

It would probably be easier if I had a more “open” router.

Try using the Pi-Hole as the DHCP server.

I have a similar request.
Since I run multiple docker containers on my machine and the port 80 is already in use, I can’t put pihole docker into network_mode = host, because I’ll get errors that the port 80 is already in use. So I stuck with building the network_mode= bridge.
This leads to a network with IP 172.25.0.0/16.
So all my pihole “clients” are the “router” ip 172.25.0.1
I can’t change the DHCP to not be on the router, because I have a wide range of static ip already asigned.
So, is there any option to still be able to see the clients IP from my “real” network, which shold be like 192.168.1.15?

Digging here on the forum I found a solution.
I have to assign to the pihole docker container a new IP (it appears as a new “physical” device on my network), so that I can use similar to network_mode= host and have no problems with port 80.
Here is the link: http://tonylawrence.com/posts/unix/synology/free-your-synology-ports/