get_client_groupids(): Gravity database not available

The issue I am facing:
Dashboard says Domains on blocklist -2
Debug log says gravityDB_open(): /etc/pihole/gravity.db does not exist

Details about my system:
Original Pi B model 256MB initially with a 2GB SD Card.
It worked fine for about 10 months until, ahem....

What I have changed since installing Pi-hole:
A bit mad, this....
I decided to install CUPS, not realising that it can take up to 2GB. I thought it would be tiny.
Before that I did a apt-get update.
... I ran out of space. I tried to manually reduced the size of one of the databases. I thought I did something along these lines Tip: How reduce DB stat size
but space issues kept hitting me.

Shutdown, copied the sd card to a 16gb card and now I'm trying to recover.
Things seem to work more or less apart from the 2 errors above.
I tried pihole -g -r but still get
$ sudo -u pihole stat /etc/pihole/gravity.db
stat: cannot stat '/etc/pihole/gravity.db': No such file or directory

The debug log does not upload from command line or web.

This is going to be a continuing problem. Spend a few bucks and get a much bigger card - a 32 GB SanDisk Ultra is about $7 US on Amazon.