Gerät beim Pi-Hole ausklammern

Hallo, ich habe vorher den Eblocker benutzt, doch leider ist die Firma nun Insolvenz und stellt ihre Dienste ein.
Beim Eblocker konnte ich jedes Gerät einzeln zuweisen ob er die Werbung blocken soll.
Pi-Hole hatte ich mir schon vorher immer mal wieder angeschaut, aber gibt es nun eine einfache Funktion wo man ein Gerät ausklammern kann beim Pi-Hole !?
Gruß

Hallo,

in der Annahme, dass du Pi-hole nicht als DHCP-Server verwendest, kannst du auf jedem Gerät manuell festlegen (in den Einstellungen der Internet-/WLAN-Verbindung), welchen DNS-Server es verwenden soll.
Gerät A Pi-hole, Gerät B Quad9/Cloudflare/…

Manuelles Setzen des DNS geht eigentlich immer, egal wer der DHCP-Server ist und was er setzt. Bei manchen Geräten kann man den DNS jedoch nicht manuell umstellen, z.B. bei Sonos Lautsprechern.

Eleganter lässt sich das ganze über dnsmasq lösen, also den zugrunde liegenden DNS Dienst von Pi-Hole. Über die MAC-Adresse kann man jedem Gerät einen beliebigen DNS-Server setzen. Einfach in /etc/dnsmasq.d eine neue Datei erstellen (sind durchnummeriert), z.B.
/etc/dnsmasq.d/04-smartdns.conf mit folgendem Inhalt:

dhcp-option=tag:smartdns,option:dns-server,54.93.173.153,81.17.17.170
dhcp-host=DC:XX:XX:XX:XX:7A,set:smartdns #AppleTV

Dadurch bekommt hier z.B. der Apple TV (DC:XX:XX:XX:XX:7A) immer Smartdnsproxy.com als DNS-Server gesetzt. Es kann natürlich jeder beliebige DNS gesetzt werden über die dhcp-option Zeile. Nach der Änderung einmal den dns neu starten, entweder über die GUI oder via pihole restartdns.

Genau diese Lösung habe ich gesucht. Allerdings funktioniert es bei mir aktuell noch nicht.
Die DNS-Anfragen laufen alle schön sauber über meine Pihole Installation auf einem RaspberryPi.
Nun möchte ich aber bestimmten Geräten den Google-DNS Server zu weisen.

Deine Erklärung oben habe ich abgeändert "smartdns" -> "google" , IP-Adresse -> "8.8.8.8,8.8.4.4"
Auch die MAC wurde aus der FritzBox herausgesucht und dort eingetragen.

Das müsste es ja eigentlich gewesen sein. Die WLAN Verbindung wurde zu den Geräten bereits schon getrennt (WLAN an Fritzbox ausgeschaltet). Ich sehe die Anfragen allerdings immernoch im Pihole.
Müssen die Geräte dafür neugestartet werden?

Es geht um Android Geräte.

Weitere Frage: In der FritzBox trage ich doch trotzdem unter dem lokalen DNS-Server meine pihole Installation ein?

Danke schonmal @marco79

Dieses Topic ist über ein Jahr alt.
Die hier vorgestelte Lösung über DHCP sollte nach wie vor anwendbar sein, sofern Pi-hole als DHCP-Server fungiert. Ich vermute mal, dass bei Dir die FritzBox DHCP-Server ist.

Sofern es Dir nicht primär um die Verwendung eines spezifischen öffentlichen DNS-Servers geht, sondern darum, bestimmte Clients nicht durch Pi-hole filtern zu lassen:
Seit Version 5 aus dem Mai diesen Jahres bietet Pi-hole client-basiertes Filtern.
Damit lassen sich einzelne Client-IPs auch so konfigurieren, dass sie nicht geblockt werden.

Ja, das ist das Problem. Pihole ist nicht der dhcp Server. Danke für den Tipp.
Habe bei den Gruppen nie durchgeblickt, aber jetzt kam der Blitz. Ich bedanke mich!