FTL went offline after following steps to configure OpenVPN

Please follow the below template, it will help us to help you!

Expected Behaviour:

FTL should be online

Actual Behaviour:

FTL is not online

Debug Token:

https://tricorder.pi-hole.net/n9yhk0aq93

You seem to have some network issues:

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the enp7s0 interface.

[✗] No IPv6 address(es) found on the enp7s0 interface.

[i] Default IPv4 gateway: 192.168.1.1
   * Pinging 192.168.1.1...
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)

The FTL crash log was cut off in your debug log. Share the full crash log from /var/log/pihole-FTL.log starting with

   [2019-05-10 20:04:00.199 10008] !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
   [2019-05-10 20:04:00.199 10008] ---------------------------->  FTL crashed!  <----------------------------
   [2019-05-10 20:04:00.199 10008] !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I’m pretty sure the networking issue started after I set the pihole server’s ip to 10.8.0.1. Not sure, though.

pihole-FTL.txt (143.8 KB)

What OpenVPN guide were you following? The FTL crash seems to be one-off, your networking issues are more important. Since you changed the server’s IP address, you need to run pihole -r to reflect that change in the Pi-hole settings.

I’ve already tried changing the IP address to 10.8.0.1 and back in /etc/openvpn/server.conf and with pihole -r.


Let me start at the beginning, to not leave out anything potentially stupid that I’ve done.

First, I installed Pi-hole, and enjoyed it for several days. Then I followed this this page and reconfigured Pi-hole to use the tun0 interface. All went well.

Then, I added a record for my DDNS hostname, as depicted here. Smooth sailing. I also set up a Full and DNS-only setup.

Lastly, I decided that I wanted to use the VPN from both internal ((W)LAN) and external (VPN) networks, and so attempted to set up dual operation. This is when things went awry.

Just tried uninstalling and reinstalling Pi-hole and OpenVPN. No dice.


Perhaps I should also mention that prior to this vpn business:

  1. I followed this to set up DNS-over-HTTPS.
  2. I’ve had an issue with FTL going offline after a reboot, but having the script below run at run level 0 resolved it.
#!/bin/bash
sudo service pihole-FTL start
sudo ufw allow 53
sudo rm -f /etc/resolv.conf
sudo ln -s /run/systemd/resolve/resolv.conf /etc/resolv.conf
  1. Now when running pihole -r, the install log shows this near the end (I assume this is caused by those network issues (that I don’t know the cause of)):
  [✓] DNS service is running
  [✓] Pi-hole blocking is Enabled
fatal: No names found, cannot describe anything.
fatal: No names found, cannot describe anything.

The No names found messages can be ignored, they are unrelated and purely cosmetic.

Were do you see issues currently? It is hard to see from your posts what issue you are currently experiencing.

FTL is offline, and the bash script above doesn’t bring it back online any more.

Make a new debug token and share the output of these commands:

dig pi.hole @127.0.0.1
echo ">stats" | nc 127.0.0.1 4711
sudo service pihole-FTL status
sudo service lighttpd status

https://tricorder.pi-hole.net/xer93w4r7j
Seems like my Pi-hole isn’t able to resolve queries now.


(base) user@minty:~$ sudo dig pi.hole @127.0.0.1
[sudo] password for user:      

; <<>> DiG 9.11.3-1ubuntu1.7-Ubuntu <<>> pi.hole @127.0.0.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 52310
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;pi.hole.			IN	A

;; AUTHORITY SECTION:
.			3600	IN	SOA	a.root-servers.net. nstld.verisign-grs.com. 2019051201 1800 900 604800 86400

;; Query time: 14 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sun May 12 16:18:48 EDT 2019
;; MSG SIZE  rcvd: 111

(base) user@minty:~$ echo ">stats" | nc 127.0.0.1 4711
(base) user@minty:~$ sudo service pihole-FTL status
● pihole-FTL.service - LSB: pihole-FTL daemon
   Loaded: loaded (/etc/init.d/pihole-FTL; generated)
   Active: active (exited) since Sun 2019-05-12 01:33:57 EDT; 14h ago
     Docs: man:systemd-sysv-generator(8)
  Process: 906 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUC

May 12 01:33:33 minty systemd[1]: Starting LSB: pihole-FTL daemon...
May 12 01:33:36 minty pihole-FTL[906]: Not running
May 12 01:33:36 minty pihole-FTL[906]: /etc/resolvconf/update.d/libc: Warning: /
May 12 01:33:38 minty su[1030]: Successful su for pihole by root
May 12 01:33:38 minty su[1030]: + ??? root:pihole
May 12 01:33:39 minty su[1030]: pam_unix(su:session): session opened for user pi
May 12 01:33:57 minty pihole-FTL[906]: dnsmasq: failed to create listening socke
May 12 01:33:57 minty systemd[1]: Started LSB: pihole-FTL daemon.
log file: udo service lighttpd status...skipping...
● pihole-FTL.service - LSB: pihole-FTL daemon
   Loaded: loaded (/etc/init.d/pihole-FTL; generated)
   Active: active (exited) since Sun 2019-05-12 01:33:57 EDT; 14h ago
     Docs: man:systemd-sysv-generator(8)
  Process: 906 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUCCESS)

May 12 01:33:33 minty systemd[1]: Starting LSB: pihole-FTL daemon...
May 12 01:33:36 minty pihole-FTL[906]: Not running
May 12 01:33:36 minty pihole-FTL[906]: /etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symbolic link to /run/resolvconf/resolv.conf
May 12 01:33:38 minty su[1030]: Successful su for pihole by root
May 12 01:33:38 minty su[1030]: + ??? root:pihole
May 12 01:33:39 minty su[1030]: pam_unix(su:session): session opened for user pihole by (uid=0)
May 12 01:33:57 minty pihole-FTL[906]: dnsmasq: failed to create listening socket for port 53: Address already in use
May 12 01:33:57 minty systemd[1]: Started LSB: pihole-FTL daemon.
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
lines 1-14/14 (END)
May 12 01:33:57 minty pihole-FTL[906]: dnsmasq: failed to create listening socket for port 53: Address already in use

You are running a different DNS resolver on port 53. Stop that resolver so FTL can use the port.

1 Like

I truly am an idiot… That brought FTL back online.

I apologize for having you go through the logs on the weekend. Thank you so much!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.