FTL v5.3.4 cannot be updated

The issue I am facing:

FTL v5.3.4 update tentative always ends with an error. I have updated successfully Pi-hole to v5.2.3 and Web Interface to v5.3.

I run pihole -up. Afterwards I run as well apt-get update and no issue detected.

It remains stuck here (all before goes smoothly without alert)


[i] FTL Checks...

[â] Detected ARMv7 processor (with hard-float support)
[i] Checking for existing FTL binary...
[i] Downloading and Installing FTL...curl: (56) OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 104
[â] Downloading and Installing FTL
Error: URL https://github.com/pi-hole/ftl/releases/latest/download/pihole-FTL-armv7-linux-gnueabihf not found
[â] FTL Engine not installed

Unable to complete update, please contact Pi-hole Support


When I look for 'https://github.com/pi-hole/ftl/releases/latest/download/pihole-FTL-armv7-linux-gnueabihf' using my MAC, I can find the file...

Details about my system:

Raspberry 4B

What I have changed since installing Pi-hole:

Last time I have updated the 3 components in a row, it was following a new Pi-Hole installation. Since, nothing added except Open VPN, which is not used by the way currently.

This is the first time I am attempting an upgrade over the fly.

I am running out of idea and if I would be not wrong I did not find similar issue (unless my bad...)

Thanks in advance for your help

Regards

Miguel

Hi,

Thanks for your hint and I might get what is sticking me.

In fact, due some 'local restrictions', I cannot get access to rawgithub. To install Pihole, Curl method did fail as well. I succeeded with the 3rd way by cloning github repo.

It seems FTL upgrade uses Curl which will pick up stuffs on rawgithub as well. This ends most likely in Port 443 timeout, leading to the error.

Indeed using a VPN, I can access to rawgithub repo from my laptop, thus it explains why the file xxxarm7xxx that is told to be not available, it is well there. BUT, my VPN provider does not want to support Pi (indeed when it detects I am sharing it through my phone to the Pi, it will block the connection).

So, I believe by using a brand new install and following the clone Git repo way, it will work.

But if anyone could have a clue to avoid such inefficient way, I would be more than happy :slight_smile:

Miguel

No, you'll still need to access GitHub to get the FTL binary.

Hi,

Well, I have installed Pihole several times and each time I succeeed using the 3rd method (clone repo). By doing so, I had all installed successfully...

What I want to say I cannot update FTL using the upgrade process, while by cloning a brand new install, that’s ok...

Miguel

Hi Msatter,

Sorry to ask basic questions but why only FTL is blocked during the process...?

I have some doubts about the root cause: when I try to access the file from my laptop (with Pihole as DNS), it fails as well. After activating the VPN, I can access it (obviously my Pihole is out of the business for that part). Please note the error I am getting is https port cannot be reached. Not so sure it is a DNS issue but rather a filtering issue...

I can well get the file but afterwards I am stuck to resume the upgrade process...

About swapping the DNS in the file you suggested, if I would be not wrong:

  • I shall update the file with the right DNS
  • Then I make a Pihole -r
  • Then Pihole -up
  • At the end, if process completed, file I changed will be restored with my Pihole IP

Did I get it correctly?

After updating DNS server, Pihole features will be obviously no longer available as all my DNS requests will be processed by the specified server, right?

Well, that changing DNS will not work, I am suddenly more confident on my growing network skills :))

Well, indeed Option 1 is the one I can only use successfully. But it means a brand new install.
I was keeping this method by looking for a potential smarter way, and obviously making a back up first with teleporter.

By the way, can I just launch the process again and it will overwrite all existing files or should unstall/remove all...?

In my previous installation, as I corrupted each time the OS (well it is by practicing that we learn :)), I started always by a clean baseline.

Miguel

Well, maybe I read wrongly.

The one I can use successfuly is with ‘clone’ in the command line

The short syntacx with curl will fail as well as the 3rd one too.

I remember now, I shall clean the pihole folder or else the install will stop.

Hi,

So to complete the loop, I solved my issue by tunneling the ethernet access of my Pi though a VPN. Error access was gone. It was really the https connection that was blocked. So afterwards, FTL updated.

What I still did not understand, I have a second Pihole running in another network. I ran as well its update but without tunneling its data and it worked! Mystery...

Anyway, when there is a 443 port error, root cause is the access being filtered.

Miguel