FTL not running on synology

I am running pihole in debian chroot on a synology NAS.

Expected Behaviour:

I should be able to have FTL running and see the proper pihole admin page.

Actual Behaviour:

FTL is not running (using both the admin page and pihole -c). Can see http://pi.hole/admin/, but the dashboard does not show graphs etc.

Debug Token:

[✗] There was an error uploading your debug log.

What is another safe way of giving you the log? It is still stored locally.

All right, finally was able to fix it. Here's a quick write-up:

Somehow I was unable to run pihole-FTL, but I was not sure why this was caused. Therefore, I checked my DHCP settings in the router (which were fine), and made sure to select the proper DNS Servers. All to no avail.
Then, I wanted to know what was actually wrong, so I ran pihole -d and since I could not upload the file and the token, started to dig myself. This then led me to an error among the lines of not being able to actually start pihole-FTL.
So I started to dig into pihole-FTL's debug which showed me that dnsmasq couldn't start because port 53 was already in use. So I ran

sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'

to find that dnsmasq actually already was running on port 53. Thus I killed the process and started pihole-FTL, which, wonderfully enough, now started without any hiccups.

The only issue I now still have is that I cannot send a debug log:


    * The debug log can be uploaded to tricorder.pi-hole.net for sharing with developers only.
    * For more information, see: https://pi-hole.net/2016/11/07/crack-our-medical-tricorder-win-a-raspberry-pi-3/
    * If available, we'll use openssl to upload the log, otherwise it will fall back to netcat.
[i] Debug script running in automated mode
    * Using curl for transmission.
[✗]  There was an error uploading your debug log.
   * Please try again or contact the Pi-hole team for assistance.
   * A local copy of the debug log can be found at: /var/log/pihole_debug.log

Is there a way to solve this?

Checked again whether I could upload a debug log without changing any other variables. Somehow, things work again!

Debug token: g4gqnk19pi

Nothing out of the ordinary, right?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.