FTL is Offline nothing obviously wrong with config

Probably similar to other people's problems, but haven't found a solution. I don't belive I did an update, upgrade or reboot. I am unsure what caused the problem. I only noticed by accident that PiHole was having problems. My pihole is not the DHCP server, has a fixed IP address. This does not seem to be causing any problems with network devices navigating.

First my FTL was offline and Lost Connection To API was showing. Then I discovered that the DNS was missing so I forced it to That allowed the sudo pihole -r to work and to download its update. DNS servers now show as:

pi@raspberrypi:/var/log $ nslookup www.google.com

Non-authoritative answer:
Name:   www.google.com
Name:   www.google.com
Address: 2a00:1450:4002:807::2004

At this point I have "Lost --- --- API" across the top of the dashboard and all the graphs are spinning circles. I have tried:

  • repair and a reconfigure options but neither fix the problem.
  • rebooting and restarting services, flushing logs and network tables

The pihole-FTL.log is https://pastebin.com/HYb72C0E

Not sure where else to try. I followed the guide to install screen and gdp. GDP was already installed and screen doesn't seem to do anything. maybe I misunderstood something.

Any ideas what to try next?


Your successful nslookup from your Pi-hole machine would imply that Pi-hole is working (i.e., if indeed run from your Pi-hole machine, with Pi-hole being the only process listening on port 53).

This would hint at a client browser issue.
Have you tried clearing your browser's cache?

Thanks for the suggestion. Clearing the cache has now showing Lost Connection To API across the top (changed from "---" on the two middle windows). Digging around in the suggestions on the forum, I note that http://192.168.1.xx/admin/api.php?overTimeDataForwards&getForwardDestinationNames returns


  • FTLnotrunning: true

Please provide a debug token generated by

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

sorry, just to be clear, that nslookup was run from the pihole machine. /etc/resolv.conf has returned to only include localhost ( has been removed by the machine)

DNS config page is set to only OpenDNS and all other checkboxes are unchecked.

debug token :

You have another DNS server claiming port 53:

*** [ DIAGNOSING ]: Ports in use
*:3128 squid (IPv6)
*:1880 node-red (IPv4)
[53] is in use by named (https://docs.pi-hole.net/main/prerequisites/#ports)
[53] is in use by named (https://docs.pi-hole.net/main/prerequisites/#ports) named (IPv4)
[::1]:953 named (IPv6)
[53] is in use by named (https://docs.pi-hole.net/main/prerequisites/#ports)

You'd have to disable or uninstall that other DNS server (likely that's BIND/named).

Interesting, seems that when I put webmin onto the pi, it (or I by mistake) started the bind dns server. stopping that has fixed the issue, thank you so much for your time!

You're welcome. :wink:

Could you do me a favour and tag an appropriate post as solution?