FTL fails to download

Expected Behavior:
During the installation of Pi-hole the install should succeed with the Root check at the beginning as well as download the FTL file from Github at the end of the install.

Actual Behaviour:
Near the end of the installation and setup of Pi-hole on a Raspberry Pi Zero W, the install checks for an existing FTL file and then attempts to download it from Github. It then comes back and says that it could not connect to Github and the FTL file failed to download because of it. I have reset and attempted the whole process over multiple times using different Raspbian OS versions. Every time it fails. Lately it has also been failing the Root check at the beginning of install as well, and then I am unable to access commands such as /etc/resolv.conf. I am also unable to retrieve the Debug Token because if it’s not allowing me to run a command then it says “-bash: pihole: command not found” This will happen for most of the commands. I have looked at many forums and websites with no success. I am also a beginner when it comes to using Linux OS or Raspbian OS so I’ll need explanations with great detail. Please help me as I’ve been messing around with this for a good 24 hours. Thank you!

Debug Token:

Debug token not possible to get

FYI: I did have the Pi-hole functioning on my first go about a month ago but took it down to design a 3D printed case for it and to also figure out how to set it up for certain devices instead of the whole network. When I tried this back on Tuesday, nothing was working, so that is when I decided to start fresh and wipe the OS. Again please help me. I would greatly appreciate it!

Try changing nameserver in the file /etc/resolv.conf to that of Google’s 8.8.8.8:

sudo tee /etc/resolv.conf <<< $'nameserver 8.8.8.8'

And select repair when run below one:

pihole -r

If that doesnt help, run below one again:

sudo tee /etc/resolv.conf <<< $'nameserver 8.8.8.8'

And try upload a debug log with below:

pihole -d

1 Like

I had the same issue as the OP when I tried to do a fresh pihole install as mine started dying every 6 hrs after a recent upgrade.
/etc/resolve.conf showed NAMESERVER 127.0.0.1 pointing to localhost, so the pihole repository was NOT reachable.
Changing it to 8.8.8.8 solved the issue…

A post was split to a new topic: Cannot install Pi-Hole

One addition, if the pihole command is not installed yet “pihole: command not found”, try do the same before running the installer.
And add the -x argument to the install command for verbose output:

sudo tee /etc/resolv.conf <<< $'nameserver 8.8.8.8'

curl -sSL https://install.pi-hole.net | bash -x

If this fails, could you post output for the install command (might want to redact some of the output) ?

I tried doing the commands. Here’s what I did with the output:

pi@raspberrypi:~ S sudo tee /etc/resolv.conf <<< $'nameserver 8.8.8.8'
nameserver 8.8.8.8

pi@raspberrypi:~ S pihole -r
bash: pihole: command not found

I then tried again:

pi@raspberrypi:~ S sudo tee /etc/resolv.conf <<< $'nameserver 8.8.8.8'
nameserver 8.8.8.8

pi@raspberrypi:~ S pihole -r
bash: pihole: command not found

pi@raspberrypi:~ S pihole -d
bash: pihole: command not found

I think that the server successfully changed, but still can’t perform pihole commands

Are you saying that I should wipe my OS and format my SD card and then reinstall everything over again except run those commands before installation?

After you reset the nameserver, rerun the installer with verbose output. If the install fails, post the output here (it may be lengthy).

curl -sSL https://install.pi-hole.net | sudo bash -x

I reset my Raspberry Pi and changed the nameserver to 8.8.8.8. Then I did the verbose installation, but still came with the same issue as before. It says:

Checking for existing FTL binary…
Downloading and Installing FTL
Error: Unable to get latest release location from GitHub
FTL Engine not installed

Thats two Zero’s that are failing.
I dont have a Zero to test/diagnose.
Keep an eye on below posting:

Do you think it could be anything to do with the hardware or is it most likely software?

I dont believe its hardware.

@Joel
Did you try that? its fixed my installation and now its running without trouble !!! since you have same issues.
thanks to @Bucking_Horn

I tried the second option that @deHakkelaar suggested:

It worked for me. At least I think that it worked for me haha

1 Like

Good news.
Though the solution offered by @Bucking_Horn is a cleaner/easier one.

Below docs can answer allot of your questions like set password:

https://docs.pi-hole.net/core/pihole-command/#web-script

Or how to configure your router so all devices connected are using Pi-hole for DNS:

https://docs.pi-hole.net/main/post-install/

Once setup shop, disconnect and reconnect all your devices from network to apply (or reboot them to be sure).

Thank you very much for your help! I’m pretty sure that I have everything set up finally. Thank you again!

1 Like