FTL failed to start due to unknown interface eth0

Expected Behaviour:

_PiHole "just works" -- as it has for three years.

Actual Behaviour:

"FTL failed to start due to unknown interface eth0" Noticed when "NaN" was seen at the top of each of the colored blocks on the dashboard.

I tried rebooting -- no effect.
I tried a repair -- worked for a few hours.

I see a couple of other discussions of this error but it seems they may not be relevant to this occurrence. This PiHole has been physically untouched for many months. The ethernet interface is likely OK as evidenced by the fact that I can RDT into it and the token was obtained.

Debug Token:


Any help on this, I wonder?

Check interfaces that are actualy available:

pi@ph5b:~ $ ip -br l | awk '{print $1}'

Check what interface is configured for Pi-hole:

pi@ph5b:~ $ grep PIHOLE_INTERFACE= /etc/pihole/setupVars.conf

Check if it has an IP:

pi@ph5b:~ $ ip -br a s eth0
eth0             UP     fe80::22e5:XXXX:XXXX:XXXX/64

If interface configured doesnt match the one available, run below and select reconfigure:

pihole -r

OK. TU @deHakkelaar. I'll get to that. Would any of that explain why this PiHole worked for many weeks without intervention/touching/reconfiguration (other than updates) and now exhibits errors and has failed, I wonder? (Sri -- I am not a LINUX guy. Just an obvious question it seems.)

Again -- TU! :<)

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.