FTL error

Please follow the below template, it will help us to help you!

Please ensure that you are running the latest version of the beta code.
Run pihole -up to update to the latest, then verify that the problem still exists before reporting it.

Problem with Beta 5.0:
[Hello, I'm receiving a ftl error, and it's not able to connect to obtain the latest release.]

Debug Token:

FTL upgrade error

Looks like it can't connect (or can't find) github. Does a ping github.com work?

Do you have unbound ?
Stop unbound else change ip at i think resolvconf.conf where that locate is.
Then retry

No, not on the pihole. It returns a "Temporary failure in name resolution".

That is with "ping github.com", "ping www.github.com", or I even tried ping -c 3 -i 5 www.github.com". Actually even attempting to ping google. Maybe I need to reinstall the OS? And then the pihole? Start from scratch?

No, no unbound, simply the pihole software alone..

Can you ping an IP address, like ping or ping

No, it wouldn't ping anything. I wiped the card and figured I'd try to start from scratch. I downloaded the latest raspian, and am flashing now.

Sho is there a direct install of the beta by any chance?

Chances are your device is configured to only use itself for DNS lookups, which is quite common with pihole setups, and now pihole isn't running then resolution is failing.

If you can ping as Dan suggests then just add another nameserver line to /etc/resolv.conf (note - this temp change should get you back up and running for you to get pihole installed)

sudo nano /etc/resolv.conf

once you add this line and save the file, DNS resolution should work again when it realises your localhost name server is down.

Edit: ah, posted too soon. If you want to install the beta from scratch you can use the steps here Installation beta - #3 by DL6ER

No. Install master and then move to 5.0

Yes you can . :+1:

From linked post:

Looks like it may not work:

At my raspberrypi it works

When it's supported by the developers there will be a notice posted. Until then this just adds more confusion and noise for us to support.

Sorry, i understand.

1 Like

Ok, after being under the weather, I was able to do the complete reinstall. This worked fine! And I'm loving the new features. Still not ready to switch the ship back fully over to the pi ad of yet. But just trying out the new feature of power client at the moment..

Thank you tremendously.