FTL Engine not installed with pihole 4.2.2

#1

I’m using pihole on a raspi (Pi-hole : v4.2.2-2-gb3898b9, AdminLTE: v4.2-2-g8f3ed415, FTL : v4.2.3).
I recently upgraded to version 4.2.2 but since a few days I even can’t connect to the web interface (even if it is listening on 80).
And when when I run pihole -up I get “FTL Engine not installed”.

systemctl status pihole-FTL says
pihole-FTL.service
Loaded: loaded (/etc/init.d/pihole-FTL; enabled; vendor preset: enabled)
Active: active (exited) since Thu 2019-05-16 20:06:45 CEST; 1h 37min ago
Main PID: 2595 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/pihole-FTL.service

May 16 20:06:45 pi-hole systemd[1]: Starting pihole-FTL.service…
May 16 20:06:45 pi-hole pihole-FTL[2595]: Not running
May 16 20:06:45 pi-hole su[2622]: Successful su for pihole by root
May 16 20:06:45 pi-hole su[2622]: + ??? root:pihole
May 16 20:06:45 pi-hole su[2622]: pam_unix(su:session): session opened for user pihole by (uid=0)
May 16 20:06:45 pi-hole pihole-FTL[2595]: dnsmasq: bad option at line 2 of /etc/dnsmasq.d/MyConfig.conf
May 16 20:06:45 pi-hole systemd[1]: Started pihole-FTL.service.

But even if I remove the second (of 2 lines) saying “bind interfaces”
the above message appears again exactly the same (?).

Can please anybody tell me what this means?
Thanks

#2

OK, it looks like that was the only issue: the 2nd line (bind interfaces) which I removed but it needed a reboot to activate.
So after the reboot it works again.

The only problem I have now is that the time (in query log) is 2 hours back even if the raspi shows the correct one…
But I think I need a new thread to ask this…
Thanks