FTL engine not installed latest everything SOLVED

v4-0

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pihole installs cleanly

Actual Behaviour:

RPI2 latest updated stretch installing pihole using curl pipe bash command it does not install FTL throwing
“Error: Unable to get latest release location from GitHub”
Then other network stuff seems to break cannot upload tokens, cannot resolve github, cannot install another curl pipe bash app am able to ping 8.8.8.8

Debug Token:

Cant upload debug log

HOWEVER after reading around I looked in resolv.conf
There were only two # lines nothing that started with nameserver.
So I added the line nameserver 8.8.8.8
Then ran pihole -r
Success it then downloaded and installed FTL.

I have close to zero understanding of how the pi accesses the internet but suspect the issues I have been having were beacuse the resolv.conf file had no nameserver line?

Anyway problem now solved if others are having similar issues.


[SOLVED] Pi-hole not working, no interface, no command, Pi now unable to resolve DNS
#2

Basically if the installer or updater fails partway through this behaviour can occur. I’m happy you found the solution!


#3

For those who are new to Linux , these are the steps I used to solve the same problem:

pi@raspberrypi:~ $ sudo nano /etc/resolv.conf
— > Paste in google’s nameserver 8.8.8.8
Save and exit nano

pi@raspberrypi:~ $ cat /etc/resolv.conf

Generated by dhcpcd
/etc/resolv.conf.head can replace this line
/etc/resolv.conf.tail can replace this line
nameserver 8.8.8.8

pi@raspberrypi:~ $

pi@raspberrypi:~ $ pihole -r

— > Existing Install Detected
— > Choose Repair (This will retain existing settings)
— > Hit Tab to move to the OK button. Press ENTER key


closed #4

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.