Fresh install, DNS/FTP not running/offline

I felt adventurous the other day and based on all the notices at the bottom of the page of new version of pihole and its components, I choose to update. I ran into issues similar to others, FTL issues. I followed steps listed in numerous threads here, none of which worked for me.

I got my backup of the pihole settings and decided to start all over. I reinstalled Raspbian Jessie, booted to it, uninstalled libreoffice, wolfram, applications like that which I don't use. Yes, I had desktop version local, so I decided to use it. I ran apt-get update, apt-upgrade, then did a "sudo curl -sSL | bash"

I did not notice any alerts during the install.

both the jessie apt-get update/upgrade and the pihole install were performed on March 25. This was an updated Jessie OS.

I log into the webpage and now it is worse that before, not it says both "DNS service not running" and "FTL offline". Yesterday it only said FTL offline.

No amount of clicking "Enable" in the navigation bar helps.

So, I locate raspbian Jessie lite in the web, download, install to microsd. This time, no update/upgrade before installing pihole. pihole installs.

According to pihole web interface it again says both "DNS service not running" and "FTL offline".

sudo apt-get update fails, the OS can't resolve any hostname whatsoever.

I just don't recall that the installation of my original install of pihole as having any kind of problem whatsoever, IIRC it was soo easy. I just can't seem to find whatever I am missing to get this working. Pi is a Model 3 B, micro sd is 16GB.

I ran the pihole -d of the latest install attempt described above; jessie lite, no apt-get upgrade before pihole install, but it seems it can't upload as the pi can no longer resolve hostnames. So I'll paste below.

pi@raspberrypi:~ $ pihole -d
This process collects information from your Pi-hole, and optionally uploads it to a unique and random directory on

The intent of this script is to allow users to self-diagnose their installations.  This is accomplished by running tests against our software and providing the user with links to FAQ articles when a problem is detected.  Since we are a small team and Pi-hole has been growing steadily, it is our hope that this will help us spend more time on development.

NOTE: All log files auto-delete after 48 hours and ONLY the Pi-hole developers can access your data via the given token. We have taken these extra steps to secure your data and will work to further reduce any personal information gathered.

[i] 2018-03-25:22:59:02 debug log has been initialized.

*** [ INITIALIZING ] Sourcing setup variables
[i] Sourcing /etc/pihole/setupVars.conf...

*** [ DIAGNOSING ]: Core version
[i] Core: v3.3 (
[i] Branch: master
[i] Commit: v3.3-0-g1e87850

*** [ DIAGNOSING ]: Web version
[i] Web: v3.3 (
[i] Branch: master
[i] Commit: v3.3-0-ge48aa29

*** [ DIAGNOSING ]: FTL version
[✓] FTL: v3.0 (

*** [ DIAGNOSING ]: dnsmasq version
[i] 2.72

*** [ DIAGNOSING ]: lighttpd version
[i] 1.4.35

*** [ DIAGNOSING ]: php version
[i] 5.6.33

*** [ DIAGNOSING ]: Operating system
[✓] Raspbian GNU/Linux 8 (jessie)

*** [ DIAGNOSING ]: SELinux
[i] SELinux not detected

*** [ DIAGNOSING ]: Processor
/opt/pihole/ line 474: $'[\E[32m✓\E[0m] \E[32marmv7l\E[0m': command not found

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the eth0 interface: matches the IP found in /etc/pihole/setupVars.conf

[✓] IPv6 address(es) bound to the eth0 interface:
   fe80::c14f:3ea1:8d07:d413 does not match the IP found in /etc/pihole/setupVars.conf (

   ^ Please note that you may have more than one IP address listed.
   As long as one of them is green, and it matches what is in /etc/pihole/setupVars.conf, there is no need for concern.

   The link to the FAQ is for an issue that sometimes occurs when the IPv6 address changes, which is why we check for it.

[i] Default IPv4 gateway:
   * Pinging
[✓] Gateway responded.

*** [ DIAGNOSING ]: Ports in use
[22] is in use by sshd
[80] is in use by lighttpd

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
shuf: /etc/pihole/gravity.list: No such file or directory
dig: '' is not a legal name (unexpected end of input)
[✗] Failed to resolve  via localhost (
dig: '' is not a legal name (unexpected end of input)
[✗] Failed to resolve  via Pi-hole (
[✓] is via a remote, public DNS server (

*** [ DIAGNOSING ]: Pi-hole processes
[✗] dnsmasq daemon is failed
[✓] lighttpd daemon is active
[✗] pihole-FTL daemon is unknown

*** [ DIAGNOSING ]: Setup variables

*** [ DIAGNOSING ]: Dashboard and block page
[✗] X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Content-type: text/html; charset=UTF-8
Date: Sun, 25 Mar 2018 22:59:06 GMT
Server: lighttpd/1.4.35

[✓] X-Pi-hole: The Pi-hole Web interface is working!

*** [ DIAGNOSING ]: Gravity list
ls: cannot access /etc/pihole/gravity.list: No such file or directory

head: cannot open ‘/etc/pihole/gravity.list’ for reading: No such file or directory
   -----head of gravity.list------

tail: cannot open ‘/etc/pihole/gravity.list’ for reading: No such file or directory
   -----tail of gravity.list------

*** [ DIAGNOSING ]: contents of /etc/pihole

-rw-r--r-- 1 root root 234 Mar 25 22:28 /etc/pihole/logrotate
   /var/log/pihole.log {
        su root root
        rotate 5
   /var/log/pihole-FTL.log {
        su root root
        rotate 3

*** [ DIAGNOSING ]: contents of /etc/dnsmasq.d

-rw-r--r-- 1 root root 1522 Mar 25 22:34 /etc/dnsmasq.d/01-pihole.conf

*** [ DIAGNOSING ]: contents of /etc/lighttpd

-rw-r--r-- 1 root root 3027 Mar 25 22:28 /etc/lighttpd/lighttpd.conf
   server.modules = (
   server.document-root        = "/var/www/html"
   server.error-handler-404    = "pihole/index.php"
   server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
   server.errorlog             = "/var/log/lighttpd/error.log"             = "/var/run/"
   server.username             = "www-data"
   server.groupname            = "www-data"
   server.port                 = 80
   accesslog.filename          = "/var/log/lighttpd/access.log"
   accesslog.format            = "%{%s}t|%V|%r|%s|%b"
   index-file.names            = ( "index.php", "index.html", "index.lighttpd.html" )
   url.access-deny             = ( "~", ".inc", ".md", ".yml", ".ini" )
   static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
   compress.cache-dir          = "/var/cache/lighttpd/compress/"
   compress.filetype           = ( "application/javascript", "text/css", "text/html", "text/plain" )
   include_shell "/usr/share/lighttpd/ " + server.port
   include_shell "/usr/share/lighttpd/"
   include_shell "find /etc/lighttpd/conf-enabled -name '*.conf' -a ! -name 'letsencrypt.conf' -printf 'include \"%p\"
' 2>/dev/null"
   $HTTP["url"] =~ "^/admin/" {

       setenv.add-response-header = (
           "X-Pi-hole" => "The Pi-hole Web interface is working!",
           "X-Frame-Options" => "DENY"
       $HTTP["url"] =~ ".ttf$" {

           setenv.add-response-header = ( "Access-Control-Allow-Origin" => "*" )
   $HTTP["url"] =~ "^/admin/\.(.*)" {
        url.access-deny = ("")
   include_shell "cat external.conf 2>/dev/null"

*** [ DIAGNOSING ]: contents of /etc/cron.d

-rw-r--r-- 1 root root 1496 Mar 25 22:28 /etc/cron.d/pihole
   34 4   * * 7   root    PATH="$PATH:/usr/local/bin/" pihole updateGravity
   00 00   * * *   root    PATH="$PATH:/usr/local/bin/" pihole flush once quiet
   @reboot root /usr/sbin/logrotate /etc/pihole/logrotate
   */10 *  * * *   root    PATH="$PATH:/usr/local/bin/" pihole updatechecker local
   57 13  * * *   root    PATH="$PATH:/usr/local/bin/" pihole updatechecker remote
   @reboot root    PATH="$PATH:/usr/local/bin/" pihole updatechecker remote reboot

*** [ DIAGNOSING ]: contents of /var/log/lighttpd

-rw-r--r-- 1 www-data www-data 516 Mar 25 22:34 /var/log/lighttpd/error.log
   2018-03-25 22:28:35: (log.c.164) server started
   2018-03-25 22:30:33: (server.c.1558) server stopped by UID = 0 PID = 1
   2018-03-25 22:30:40: (log.c.164) server started
   2018-03-25 22:31:56: (mod_fastcgi.c.2702) FastCGI-stderr: PHP Warning:  unlink(../custom_disable_timer): No such file or directory in /var/www/html/admin/api.php on line 47
   2018-03-25 22:33:59: (mod_fastcgi.c.2702) FastCGI-stderr: PHP Warning:  unlink(../custom_disable_timer): No such file or directory in /var/www/html/admin/api.php on line 47

*** [ DIAGNOSING ]: contents of /var/log

*** [ DIAGNOSING ]: Pi-hole log
-rw-r--r-- 1 dnsmasq root 0 Mar 25 22:28 /var/log/pihole.log
   -----head of pihole.log------


    * The debug log can be uploaded to for sharing with developers only.
    * For more information, see:
    * If available, we'll use openssl to upload the log, otherwise it will fall back to netcat.

[?] Would you like to upload the log? [y/N] y
    * Using openssl for transmission.
[✗]  There was an error uploading your debug log.
   * Please try again or contact the Pi-hole team for assistance.
   * A local copy of the debug log can be found at: /var/log/pihole_debug-sanitized.log

pi@raspberrypi:~ $

Your version of dnsmasq is too old.

You have two options:

Or: beta-testing FTLDNS :slight_smile:


Thanks. I followed the "How do I revert to a previous version of Pi-hole? FAQs v3-3" and it does now seem to be doing resolution and blocking, it doens't update its stats. No number of domains blocked, no number of queries blocked. No graphs. I've tried different USB power sources, two up to 2.5 amps 5v. One came from osmc and its graphical desktop wasn't alarming about undervoltage before I shut it down to steal its power source for this pi-hole effort.

I've got my teleporter backup, whitelist, blacklist, and dhcp reservations.

At this point, I am losing confidence in it if other things are not working. Even the superficial graphs and counters indicate some malfunction somewhere. This install has been poked and proded, it might be time to call it. If the debug doesn't pin point exactly where it is, you could let me know and I can start all over with a fresh img, but please help me with the right steps to get a 100% working system. Jessie, Jessie lite, or Stretch lite? Do I update/upgrade before installing with the curl script or after?

BTW, earlier yesterday evening, while waiting for your response, I found another microsd and put stretch lite on it, did the update/upgrade, then the curl install. It had the missing graphs and counters too. I'm not sure what I'm missing, I had no issue whatsoever 1-2 years ago when I first setup pi-hole on a pi.

Your debug token is: z9wmhosdt2

OH!, I just noticed a teaser post about the graphs issue affecting someone else. I cleared the cache and all is well with the graphics.

So I'm on;

Pi-hole Version vDev (HEAD, v3.2.1-0-ge602008) Web Interface Version vDev (HEAD, v3.2.1-0-g31dddd8) FTL Version vDev (v2.13.2 , v2.13.2 )

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.