Frequent DNS Timeout


#1

Hi,

Multiple times per day i receive a DNS timeout when trying to access the internet. I can see that the DNS has timed out if i try “nslookup www.google.com” on my Windows laptop.

My setup is running Pihole on a Ubuntu VM on HyperV. During the loss of internet connectivity (due to DNS timeout) i can still access the local instance of Pihole which is running on an internal IP (192.xx.xxx.xx) so i dont think its related my network.

The DNS will usually comes back within 5 minutes of hitting the timeout.

Do you have any insights on what the issue could be?

Debug Token: xyqj1e90kr

Thanks


#2

The one thing I note in your debug log is this - the Pi-Hole should be able to resolve a DNS entry using 8.8.8.8.

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] 1479646169.xiazaidown.com is 0.0.0.0 via localhost (127.0.0.1)
[✓] 1479646169.xiazaidown.com is 0.0.0.0 via Pi-hole (192.168.86.11)
[✗] Failed to resolve doubleclick.com via a remote, public DNS server (8.8.8.8)

Run this command from the Pi-Hole host terminal and post the results. This will show if it’s repeatable.

dig doubleclick.com @8.8.8.8

Is this problem on any time pattern that you have noticed or is it random?

Did this problem exist before you loaded this block list - https://tspprs.com/dl/cl1 ?

And, what is the output of this command from the Pi-Hole host terminal?

echo ">stats" | nc localhost 4711


#4

Oct, 11: DNS key exchange

Try to disable DNSSEC checkbox in Settings/DNS

I faced the same issues and after unchecking everything went fine. I’m going to re-enable the DNSSEC after a few days.


#5
administrator@pihole:~$ dig doubleclick.com @8.8.8.8

; <<>> DiG 9.11.3-1ubuntu1.2-Ubuntu <<>> doubleclick.com @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4746
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;doubleclick.com.               IN      A

;; ANSWER SECTION:
doubleclick.com.        299     IN      A       216.58.199.110

;; Query time: 19 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Thu Oct 11 13:51:54 UTC 2018
;; MSG SIZE  rcvd: 60
administrator@pihole:~$ echo ">stats" | nc localhost 4711
domains_being_blocked 1146668
dns_queries_today 44840
ads_blocked_today 7977
ads_percentage_today 17.789919
unique_domains 1852
queries_forwarded 19790
queries_cached 17073
clients_ever_seen 4
unique_clients 4
dns_queries_all_types 44857
reply_NODATA 1
reply_NXDOMAIN 9
reply_CNAME 50
reply_IP 73
status enabled
---EOM---

The problem is totally random and with no obvious patterns observed. I should add that i’m using OpenDNS as the upstream DNS if that helps.

Besides let me try disabling this block list and let you know how it goes: https://tspprs.com/dl/cl1

I cant remember what the default selection was but not sure if this has any impact on my issue?

Cheers!


#6

This setting is not enabled on my installation so i’m afraid it’s not related to DNSSEC in my case.


#9

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.