Feedback webinterface


#1

After the update to version to pi-hole version 2.11.2 and web interface version 2.3.1 I wanted to give some feedback.

The feedback is regarding the frontend part of the web interface. This is only feedback and is not to criticize the people who made the webinterface.

  1. If I collapse the sidebar to the “icons only mode”, it will not stay this way when I switch to a other page within the web interface.
    It will reset itself to the default size. It would be nice if the sidebar stays collapsed if the user choose for the minimized sidebar.

  2. the widgets on the top of the index page are selectable. This is in my opinion not very usefull and makes the web interface less “professional” looking.
    This also applies to the “MAIN NAVIGATION” text in the sidebar.

  3. if a page takes a little longer to load it will show the “javascript is disable” till the whole page is loaded. After that everything is back to normal. This will happen when going to the settings page.
    It would be nice if that page is not show. It is a little bit distracting and maybe a bit confusing for new users.

  4. It would be nice if the logout button gets a confirm screen. This to prevent accidental logout(misclick). This will give the web interface a better look.

  5. The status(active, Load and memory usage) can be clicked, but have no use.

Thanks for reading.

Again this is only information and is not to criticize the people who made the web interface.


#2

Hi there, thanks for the feedback!

I’ve moved this topic to General for now (it can be moved around at any time!) As I think it probably fits that category a bit better than Feature Requests. (Note to self: We could probably do with a bug report/feedback link to the github repos)

  1. Yeah, this is a good point and certainly something we can look into!

  2. Could you expand on this a bit? I’m not sure I see the issue… do you mean the text is selectable?

  3. I’m unable to reproduce, what hardware are you running pi-hole on?

  4. Definitely a good idea! @DL6ER / @Mcat12 will probably be able to do it before I can even think about it…

  5. This is already fixed in the next release!


#3

Thanks for your reaction.

2 I included a screenshot of the selectable text. When I see the “Widgets” on the top I dont want to select the text inside of the “Widgets”. I think it makes more sense if the “Widget” is like a solid object(so without the ablilty to select the text inside the “Widget”)

3 I am running pi-hole on a raspberry pi 3(first version), I bought it just when it came out.
It is running on the default version of RASPBIAN.
I got “javascript is disable” message on google chrome, internet explorer and microsoft Edge. The message is mosly visable after refreshing (F5) the settings page.


#4

Hmmm, but why are you trying to select it in the first place? Surely if you don’t try and select it, it won’t be selected… :wink: Is there something on the page that you would like to select?

OK, I’m able to reproduce that now on most pages, but only if I mash F5 on my keyboard rapidly! I wonder what is causing that… :confused:


#5

The select issue is not really a problem, but feels more polished.

the javascript issue has something to do with the way the web interface is loaded.
If you use the Google chrome DevTool(f12) it will show that the php page is loaded first, and after that the javascript will load.

I am not sure tho, I am more a .net developer than a web developer. :slight_smile:


#6

The page itself must load first, then everything else gets loaded, so I don’t think it has to do with how it’s loaded. I’ve never seen/heard of this bug before, and it seems like it shouldn’t normally happen because the JS file is being loaded pretty much instantaneously from cache, but not executing until everything else does. Do you have any browser extensions that might cause this?


#7

It will happen on multiple browers, I tried Google Chrome, Internet Explorer and Edge. All with the same result.
You see the javascript screen for a few milliseconds or sometimes half a second, after that everything is fine. so brower extensions are not causing it.


#8

I haven’t been able to reproduce this one… Is this happening on all clients?