Failed Installation - Please help

Setup new Pi 3 B+ with fresh install of raspbian stretch lite to configure as my Pi-hole. Connected to my router (edgerouter x) directly via ethernet cable. Using SSH I ran the installation script and everything seemed to be working correctly. Reserved a static ip within my router settings for the pi.

However, I was not able to access the web admin page for Pi-hole. Then I noticed that it seems like the installation may have failed because I was not able to use debug command either. I then tried to restart the installation of Pi-hole again and I only get this message now: "Could not resolve host:".. I tried to ping a few sites like and got the same message, however I can ping these sites using the IP address and not domain names.

Where do I go from here? Thank you!

Copied SSH text from installation:

root@raspberrypi:/home/pi# curl -sSL | bash

[✓] Root user check

     :cccclll:.      ..,,
      :ccccclll.   ;ooodc
       'ccll:;ll .oooodc
             .. ','.
    .........  ....  .........
    ..........      ..........
    ..........      ..........
    .........  ....  .........

[✓] Disk space check

[✓] Update local cache of available packages

[✓] Checking apt-get for upgraded packages... 17 updates available
[i] It is recommended to update your OS after installing the Pi-hole!

[i] Installer Dependency checks...
[✓] Checking for apt-utils
[i] Checking for dialog (will be installed)
[✓] Checking for debconf
[✓] Checking for dhcpcd5
[i] Checking for git (will be installed)
[✓] Checking for iproute2
[✓] Checking for whiptail

[✓] Stopping dnsmasq service...

[✓] Stopping lighttpd service...
[i] Using interface: eth0
[i] Using Google DNS servers
[✓] Set IP address to
You may need to restart after the install is complete
[i] Unable to find IPv6 ULA/GUA address, IPv6 adblocking will not be enabled
[i] IPv4 address:
[i] IPv6 address:
[i] Web Interface On
[i] Logging On.
[✗] Check for existing repository in /etc/.pihole
[✓] Clone into /etc/.pihole

[✗] Check for existing repository in /var/www/html/admin
[✓] Clone into /var/www/html/admin

[i] Main Dependency checks...
[i] Checking for bc (will be installed)
[✓] Checking for cron
[✓] Checking for curl
[i] Checking for dnsmasq (will be installed)
[i] Checking for dnsutils (will be installed)
[✓] Checking for iputils-ping
[i] Checking for lsof (will be installed)
[i] Checking for netcat (will be installed)
[✓] Checking for sudo
[✓] Checking for unzip
[✓] Checking for wget
[i] Checking for idn2 (will be installed)
[i] Checking for sqlite3 (will be installed)
[i] Checking for lighttpd (will be installed)
[i] Checking for php-common (will be installed)
[i] Checking for php-cgi (will be installed)
[i] Checking for php-sqlite3 (will be installed)
root@raspberrypi:/home/pi# reboot

After you installed the OS did you sudo apt-get update and sudo apt-get upgrade?

Once you did those, you should run

sudo apt-get install bc dnsutils lsof netcat idn2 sqlite3 lighttpd php-common php-cgi php-sqlite3

Once the packages are installed, re-run the Pi-hole install command (from user pi - you don't have to be root).

curl -sSL | bash

Thank you for quick response! I poked around in the raspi-config and the rebooted again. No idea what the problem was but I was able to resolve domain names again finally. I re-ran the installer and looks like everything is working great now! Thank you


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.