Fail2ban prevents pihole webGUI from loading up

Please follow the below template, it will help us to help you!

Expected Behaviour:

[web gui of pihole coming up.]

Actual Behaviour:

[connection times out. i did a little test of mine. turns out fail2ban is doing this. however, this server has some functions exposed to the internet so fail2ban is mandatory for me. Notes:this server runs Open Media Vault. and the fail2ban plugin is in use. ]

Debug Token:

[https://tricorder.pi-hole.net/t56h36ujm2]

I don’t think there is anything we can do on the Pi-hole end to fix this.

And if you try another port for you pihole? Default port is 80, maybe you can try port 8080 and then open the admin webgui like this:
192.168.x.x:8080/admin/

i was able to find out what jail causes this. a jail called omv-web GUI. a jail for the open media vault admin page. its set to ports : http and https . filter is omv-webgui

fail2ban creates lots of lines in iptables, i used only 2 lines, only allow your internal ip range, else DROP

my issue is resolved. i just disabled the omv-webgui jail. this would not have any effects on my security because i have set my router to block ports related to http and https. so no one from outside can even see the webGUI. thanks for your help.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.