Expand width of Type column on Grp Mgmt > Domains

Please expand the width of the type column so that it does not truncate the entry type. I should not need to click the drop down of each entry to see which type it is. This is a problem even when my browser is full screen.

I am using Firefox v80 on Windows 10.

Thanks

I'm not seeing the behavior you describe on any of my running Pi-holes, on several different browsers. It is only when I narrow the browser window significantly that this column becomes difficult to read:

Even though your browser is set to full screen, if you are using the boxed layout for the Pi-hole admin GUI, the page you are viewing won't use all the screen real estate.

On the Settings > API/Web Interface page, deselect the "Used boxed layout" and save the change; this should resolve your problem.

1 Like

This is an issue only occurring when you use long domains/regex entries.

I've opened an issue on github already

If you agree this is an issue rather than a missing "feature", I would ask you to close this request.

(at)yubiuser I'm going to disagree with you that this is only occurring when using long domain names as in my case I do not have any. It's likely a similar fix though.

(at)jfb Thanks this did fix the issue for when my browser is full screen since it got rid of that unnecessary margin. I will say though that the Type column seems to aggressively shrunk and I'm not sure why.

Example:

You can't see that they are all "Exact Whitelist"?

What layout are you using? (Boxed or unboxed)

At some point if the window isn't wide enough to display everything, some elements will have to shrink. It is likely we can improve how the sizing works for each column relative to the others. I would keep your browser window at maximum width for now.

(at)DanSchaper. When I put in the ticket it was more compressed and I should have posted a screenshot. See the screenshot in my second reply for a better example.

I'm not sure why it was more spread out now. Yes.. in that screen shot I can certainly infer that the type. But that being said, based on the size of the contents of the various fields there's no reason for it to be collapsed at all.

I did get my work around from jfb. I wasn't aware I could remove the empty margins bracketing the page and with them gone I'm happy.

Can you run pihole -d and post the token please? I'd like to check the output from lighttpd.

(jfb) Thanks and I will likely just use it full screen when I'm on that page. If I may just say one other thing, it seems like all the columns on that page are dynamically sized when many of the elements are of a fixed width (Type, status, group assignment, action). Not sure if that's useful information to you or not but seems like something that could be adjusted.

(at)DanSchaper Sure. https://tricorder.pi-hole.net/od4q7fq4aa

Okay, two things:

  1. I see you have an external.conf file, though it looks like it is just for a TLS termination, it may be part of the cause.

  2. There are some errors in the logs:

-rw-r--r-- 1 lighttpd lighttpd 706 Sep  1 11:44 /var/log/lighttpd/error.log
   2020-08-30 03:08:02: (server.c.1818) logfiles cycled UID = 0 PID = 10110 
   2020-09-01 09:20:04: (mod_fastcgi.c.421) FastCGI-stderr: PHP Notice:  Undefined index: type in /var/www/html/admin/scripts/pi-hole/php/groups.php on line 507
   2020-09-01 11:37:40: (mod_fastcgi.c.421) FastCGI-stderr: PHP Notice:  Undefined index: type in /var/www/html/admin/scripts/pi-hole/php/groups.php on line 507
   2020-09-01 11:37:48: (mod_fastcgi.c.421) FastCGI-stderr: PHP Notice:  Undefined index: type in /var/www/html/admin/scripts/pi-hole/php/groups.php on line 507
   2020-09-01 11:44:44: (mod_fastcgi.c.421) FastCGI-stderr: PHP Notice:  Undefined index: type in /var/www/html/admin/scripts/pi-hole/php/groups.php on line 507

You are correct that it is for TLS. It's old and the cert is broken, I can certainly disable that. I have been connecting via HTTP.

This is, frankly, an installation that's been in place for some time and has been carried along through upgrades. Is there a simple way I can audit/validate the files in place?

What domain name are you using to connect? There's a couple different pihole-2xx domains, and the external.conf has an http>https redirect:

     $HTTP["scheme"] == "http" {
       $HTTP["host"] =~ ".*" {
         url.redirect = (".*" => "https://%0$0")

Using domain names other than pi.hole or the bare IP can cause issues with scripts not working quite correctly.

Also, it doesn't look like there is any real IPv6 address on the node but Pi-hole has been configured for it anyways:

*** [ DIAGNOSING ]: Name resolution (IPv6) using a random blocked domain and a known ad-serving domain
[✓] www.sefp-boispro.fr is :: via localhost (::1)
[✓] www.sefp-boispro.fr is :: via Pi-hole (fe80::edfe:dfbe:97a1:f97a)
[✗] Failed to resolve doubleclick.com via a remote, public DNS server (2001:4860:4860::8888)

If you don't have IPv6 connectivity to the Internet then it would be best to just disable all of that and see if the display corrects itself.

http://pihole-01.threesheets.local - It's a setup that's survived a couple re-designs of how I have things arranged in my home network. Learning as I go. The SSL setup was an old config that I had honestly forgotten about. I'm either going to trash that external.conf or fix it so it's correct.

Good to know. I actually have a second pihole as secondary DNS so the rest of the household didn't get their pitchforks every time I did some kind of server maintenance. I developed a habit of referencing them directly. I'll keep this in mind in the future.

Done.

I'll make the adjustments and let you know. I appreciate the deep dive.

Thanks!

It is exactly the same issue. The width of the columns is calculated for the whole table not only the fist page. Select "All" in the drop-down and you will see.
In your case it is likely the entry xboxexperiencesprod.experimentation.xboxlive.com that causes this issue.