Error when browsing clients with over 100k queries



I deployed a pi-hole in a busy environment, and I noticed some small scaling issues primarily on the web-UI. (Over 100 clients, millions of queries per 24hrs.)

It seems to scale alright on the dashboard, apart from the client chart running out of colour resulting in the majority of clients being black lines, nonetheless, that’s not the biggest issue.

When clicking on a client that generated over 100k requests, the recent queries view seems to not work, it generates the error ”An unknown error occurred while loading the data.”, this error shows as an alert. In the request view, the server seems to respond with 500.

I tried generating a debug log, but the button greys out and never seem to finish.

I’m running this using the docker image pihole/pihole, any workarounds or ideas to get some useful debug to see why this happens?


Try to generate a debug log from the command line. At the end, you will be asked if you want to upload the log. Answer “Y” and the log will upload and you will get the token.

pihole -d


Aha! That command proved more useful. I’m seeing PHP memory allocation errors, lets tweak these settings and see if that resolves the issue.


Conclusion: It seems to allocate more than what PHP 7’s default memory limit is. (128M)

I assume the code for viewing individual clients wasn’t quite designed to view clients with over 100k or even 1M total queries in the last 24hrs. Perhaps some improvement on the loading of this data could be done, but I wouldn’t categorise it as a high priority issue, due to the low likelihood of people using it in such a busy environment.


I got pie hole whit over 200 mil queries a day at work😁


Does a single client go over 100k queries? If so did you also have to work with the PHP process needing more then 128MB of RAM space to accommodate for it when you view the client page?


We set the php7 memory to like 1024 mb, running the pi hole on a WM


Have you attempted this is multiple browsers Chrome has a memory issue that has prevented the query log from loading properly for several month i personally fixed this by using Firefox


We are working on a new web/API architecture which will solve this issue by paginating the query log.


That’s good to hear! Looking forward to trying this out once it’s pushed. :slight_smile:


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.