Error adding adlist or domain to Pihole on Raspberry Pi

I installed Pihole 2-10-2024 on a Raspberry Pi
I added one adlist at that time without issue.

Today I try to block a domain I get error message:
X Error Something went wrong!
While adding INSERT or IGNORE: Attempt to write a readonly database
Added 0 out of 1 domain

When I try to add an adlist, I get error message:
X Error, something went wrong!
Wile executing: attempt to write a readonly database
Added 0 out of 1 adlists

I have done nothing to Pihole after installation. I only set up DHCP immediately after installing.

It worked fine 2-10-2024 but gives these error messages today.

I ran debug log but I do not know how to read it or copy it. I did get a link to share with support if needed.

Please help!
Thank you

Please post this link.

Fixed it myself. I ran gravity update twice, logged out of Pihole, logged in, I was able to add domain blacklist and adlist, did gravity update again, logged out and back in and everything is working fine now.