Err_name_not_resolved

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pings to 8.8.8.8 should return. I should be able to open google.com with the router using the pi-hole IP

Actual Behaviour:

Pings to 8.8.8.8 return, but trying to open google.com gives err_name_not_resolved and router will reset back to DNS set by ISP (75.75.75.75)

Debug Token:

https://tricorder.pi-hole.net/2chxi7atps

Thanks in advance!

Edit - this appears to be a possible firmware issue with my router (Netgear R7800). It's obviously not an issue with the pi-hole. Thank you for your help!

Is this limited to a single client, or are you seeing this on more than one client?

Your debug log shows that Pi-hole is working properly.

From both the client (not via ssh session to the Pi) and from the Pi terminal (run each command on each platform), please post the outputs of the following:

nslookup pi.hole

nslookup google.com

nslookup google.com 192.168.1.69

Thanks for your response! It's definitely on every PC in the house. Apologies in advance if I get terminologies wrong (I am brand new to all of this)

From the pi -

pi@raspberrypi:~ $ nslookup pi.hole
Server:		127.0.0.1
Address:	127.0.0.1#53

Name:	pi.hole
Address: 192.168.1.69
;; connection timed out; no servers could be reached
pi@raspberrypi:~ $ nslookup google.com
Server:		127.0.0.1
Address:	127.0.0.1#53

Non-authoritative answer:
Name:	google.com
Address: 216.58.194.206
Name:	google.com
Address: 2607:f8b0:4005:808::200e
pi@raspberrypi:~ $ nslookup google.com 192.168.1.69
Server:		192.168.1.69
Address:	192.168.1.69#53

Non-authoritative answer:
Name:	google.com
Address: 216.58.194.206
Name:	google.com
Address: 2607:f8b0:4005:808::200e

From a client -

PS C:\> nslookup pi.hole
Server:  UnKnown
Address:  192.168.1.1

DNS request timed out.
    timeout was 2 seconds.
Name:    pi.hole
Address:  192.168.1.69
PS C:\> nslookup google.com
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown
Address:  192.168.1.1

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out
PS C:\> nslookup google.com 192.168.1.69
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown
Address:  192.168.1.69

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
Non-authoritative answer:
DNS request timed out.
    timeout was 2 seconds.
Name:    google.com
Address:  216.58.194.206

From this PC, what is the output of this command from the command prompt:

ipconfig /all

PS C:\> ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : DESKTOP-4EHJMB1
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GbE Family Controller
   Physical Address. . . . . . . . . : 4C-CC-6A-01-D9-96
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::3083:5477:e5b4:31cf%7(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.10(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Monday, April 6, 2020 5:58:34 PM
   Lease Expires . . . . . . . . . . : Tuesday, April 7, 2020 5:58:33 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 105696362
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-25-6C-E0-7F-4C-CC-6A-01-D9-96
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet 3:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : TAP-ProtonVPN Windows Adapter V9
   Physical Address. . . . . . . . . : 00-FF-E7-41-F3-9B
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

The PC is configured to use the router for DNS, and the router must be configured to use Pi-hole DNS. I suspect the problem lies at the router.

Let's separate the PC from router DNS.

  1. Manually assign the IPv4 interface on the PC to use Pi-hole DNS only.
  2. Clear the DNS cache on that PC with ipconfig /flushdns
  3. Repeat the three commands you ran before from that PC.

You're definitely on the right track - it seems to be a router issue. I'm using a Netgear R7800.

PS C:\> nslookup pi.hole
Server:  raspberrypi
Address:  192.168.1.69

Name:    pi.hole
Address:  192.168.1.69
PS C:\> nslookup google.com
Server:  raspberrypi
Address:  192.168.1.69

Non-authoritative answer:
Name:    google.com
Addresses:  2607:f8b0:4005:809::200e
          172.217.6.78
PS C:\> nslookup google.com 192.168.1.69
Server:  raspberrypi
Address:  192.168.1.69

Non-authoritative answer:
Name:    google.com
Addresses:  2607:f8b0:4005:809::200e
          172.217.6.78

Edit - I'm looking more into the router angle. Since you said my debug looks like it's working properly (I had no idea, which is why I posted here), and manually setting my PC's DNS to the pi hole seems to function correctly, I'm going to focus on the router. Thank you for the help!

You have some options with routers.

  1. If they don't play nice, then use Pi-hole for DHCP and disable DHCP on the router.
  1. If you can't disable DHCP on the router, then try restricting the IP range of the DHCP to a single IP address (the IP of the Pi-hole). Then enable DHCP on the Pi-hole on a non-overlapping IP range.

  2. If you want to keep using the router DHCP, then start with disabling IPv6 on the router. IPv6 can result in DNS bypassing Pi-hole.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.