EDNS buffer size

Hi,
how can I set the EDNS buffer size?

I tried in “/etc/dnsmasq.d/01-pihole.conf” write “edns-packet-max=1232” but without success.

Thanks

edns-packet-max=<size>
Specify the largest EDNS.0 UDP packet which is supported by the DNS forwarder.
Defaults to 4096, which is the RFC5625-recommended size.

What do you mean by

?


Here is recommended value = 1232 B, “that will not cause fragmentation on typical network links”.

There are settings for some DNS resolvers/servers but not for dnsmasq or Pi-hole.

Do you think, that is an another atribute to set in Pi-hole?

The link you reference is for operatiors of public DNS resolvers. Pi-Hole/dnsmasq is not one of these.