Domain showing as 'none' on a single client


#1

Expected Behaviour:

Domain should be showing correctly

Actual Behaviour:

Domain shows as ‘none’.

Debug Token:

Will try and get this, but currently away from home.
EDIT - debug token is - 3lwyhw5aim

I have tried restarting the pi, restarting FTL, checking for updates but cannot resolve it. I am a complete noob to Linux so am struggling here. The device that is querying ‘none’ is a Dahua security camera. There is the possibility the fault is with the camera, but thought I would try here first. I have run wireshark and I am only seeing ARP/IGMP/SSDP traffic, none of which has a timestamp that matches the pihole logs.

Any help is appreciated.


#2

What do you see when you grep the Pi-hole logs for the camera IP address ?

grep <CAMERA_IP_ADDRESS> /var/log/pihole.log | tail -20


#3

Feb 6 00:49:18 dnsmasq[4556]: query[A] none from 192.168.1.150

Repeated for different time stamps.


#4

So your client (drivewaycamera) is querying specifically the domain none. This is no Pi-hole issue and everything is behaving as expected.


#5

Thanks for clarifying that. I will now head to some ip camera forums to see if they can suggest why, or how it can be stopped. Still not sure why it does not appear on wireshark.
Thanks again.