Domain not blocked when expected to be blocked


#1

Expected Behaviour:

I added https://raw.githubusercontent.com/chadmayfield/pihole-blocklists/master/lists/pi_blocklist_porn_top1m.list to the Settings > Block Lists and expect that sites like pornhub.com will be blocked

Actual Behaviour:

pornhub.com is still accessible

If I add pornhub.com to the Blocklist (wildcard) then I can confirm that pornhub.com is blocked. But I expect that it will be blocked using the gravity list.

Debug Token:

22slxqmlt9

https://raw.githubusercontent.com/chadmayfield/pihole-blocklists/master/lists/pi_blocklist_porn_top1m.list


#2

It seems to be blocking now. Is there gap between the list updated and it actually starts to block? Thanks.


#3

The block list you referenced blocks “pornhub.com”, but not “www.pornhub.com”. These are two different domains and it is likely that the domain you were able to access was “www.pornhub.com.” Here is a quick way to check your pihole.log and see if this is the case - this command will find every instance of “pornhub” in your log.

sudo grep pornhub /var/log/pihole.log

If “pornhub.com” was shown as blocked, and “www.pornhub.com” was not, this was the problem.


#4

In that case, what do I do so that for all domain listed in https://raw.githubusercontent.com/chadmayfield/pihole-blocklists/master/lists/pi_blocklist_porn_top1m.list the www equivalent of the domain names are block as well?

It is strange that when I randomly test the sites listed there, not all of them blocked while pornhub is remain blocked.


#5

Pornhub is likely blocked because you have blacklisted it as a wildcard.

If the public block list you are using does not adequately block the “www” equivalents, then feedback to the list maintainer would be in order.


#6

Actually I don’t think the issue is about with/out WWW. Trying out sites listed on the above list, some of them that are blocked on Chrome I still can access through Firefox. How is that even possible?


#7

Firefox has an option to run it’s own filtering on it’s own DNS. When you do this, your DNS traffic bypasses Pi-Hole. Check your Firefox options and disable this feature.