DNSMASQ warn after setting pihole as DHCP

Dear all,

i customize pihole as DHCP and enable the feature.
The DHCP in my FritzBox is disable.

Now i get following warning in pi-hole diagnosis:

But i can't find any error in my DHCP-Settings:

  • Core vDev (development-v6, 92e741fd)
  • FTL vDev (development-v6, 04cf2e83)
  • Web interface vDev (development-v6, 1dcf90bd)

Can somebody see the error?


Best regards

Do any of the suggestions in this post help (which is for v5 but I think still applies in this role)?

thank's for the link!
No of the suggestions solved the problem.

Could it be done with the netmask in the DHCP-Settings?

I set it like described to but after save, the field is blank?!


You could certainly try entering it to match your network. When set to auto, I don't know if it's picking it up from the network or if it's using some logic based on the IP range (eg setting a /8 for a 10.x.x.x network).

Make sure Pi-hole is configured to use the correct interface in use. Ie, that in this case you're using eth0 for the network, not wlan0 or something else, leaving eth0 devoid of addresses.

This may be a simple displaying artifact mistakenly assuming a null IP address means none, we'll check that.

It is taken from the interface itself, more previously from the (hopefully static) address assignment.

@GerdRuetten could you please show the output of ip a on your Pi-hole?

1 Like

Hi, sure!

root@ProxmoxCT-pihole:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host noprefixroute 
       valid_lft forever preferred_lft forever
2: eth0@if489: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether a2:30:bf:b6:4c:a7 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet brd scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fd00::a030:bfff:feb6:4ca7/64 scope global deprecated dynamic mngtmpaddr 
       valid_lft 4102sec preferred_lft 0sec
    inet6 2a00:6020:4eb5:3100:a030:bfff:feb6:4ca7/64 scope global dynamic mngtmpaddr 
       valid_lft 3490sec preferred_lft 3490sec
    inet6 fe80::a030:bfff:feb6:4ca7/64 scope link 
       valid_lft forever preferred_lft forever
3: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 02:42:4d:e3:80:9f brd ff:ff:ff:ff:ff:ff
    inet brd scope global docker0
       valid_lft forever preferred_lft forever

OK, i test it.

If i set the netmask to i get no error.
If i change back to i get the error

What do you mean?

Pi-hole running under proxmox and in proxmox i set a static IP ... see:

You've set the address to which effectively means a netmask of exactly one address (the same as The correct setting in your case would be which is

This also perfectly explains the issue and the warning you were seeing. FTL looked at the interface configuration and saw that the entire network consists of only one IP address. This means there were obviously no more appearances available it could hand out to others via DHCP, triggering the warning to make your aware of this.

Have a look at CIDR - Wikipedia (German) if you want to find out more about this.

1 Like

I'm an idiot

Thank you very much for the support!

I changed the entry in Proxmox to /16 and now I no longer receive a warning message, even with a netmask of

We never stop learning :slightly_smiling_face:

1 Like