Dnsmasq daemon is failed


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

dnamasq working, and DNS directed to pi-hole

Actual Behaviour:

IP is assigned, however the DNS server assigned does not correspond with the pi-hole server (192.168.1.158, 8.8.8.8, 8.8.4.4)

Debug Token:

fup366g6vw


#2

Why do you suspect the dnsmasq daemon is failing, any errors displayed ?
What is results from below two ?

sudo systemctl status dnsmasq -l

sudo netstat -nltup | grep "Proto\|:53 "

Assigned to which box ?
Is the 192.168.1.158 IP your Pi-hole box ?

On a Windows or Linux client PC, you can run below one to test DNS resolution if 192.168.1.158 is your Pi-hole IP address:

nslookup pi.hole 192.168.1.158


#3

Thank you, I reverted to a previous image, and is working now. The issue presented after I enabled the wlan and reconfigured pihole to the fixed wlan ip address instead of the eth0. This time every thing went ok, I had tried at least 8 times before. Don’t know what I was doing wrong before.

A weird issue remains only on my main pc (Mint) I get he DNS server assigned to 192.168.1.158, 8.8.8.8, 8.8.4.4, the pihole is on .18 and the dhcp available is from .100 to .250. If I manually set it to .18 it does work fine. I guess is something residual, I have deleted the network connection to no effect.

$ nslookup pi.hole 192.168.1.158
;; connection timed out; no servers could be reached

$ nslookup pi.hole 192.168.1.18
Server: 192.168.1.18
Address: 192.168.1.18#53

Name: pi.hole
Address: 192.168.1.18


#4

Setup your router as described in this FAQ:

If not possible on the router because of necessary settings lacking:

And this:


#5

Thank you, I do have it as my DHCP server, and the one on the router deactivated. Unfortunately the router has no option to modify or turn off the DNS server, I counting on it being deactivated along with the DHCP.