DNS Settings Synology RT1900ac questions (resolved)


as my network setup is different to other ones, I created a new topic, I hope that is okay.

So my setup is:

Cable modem --LAN CONNECTION-- Synology router (bridge mode, hosts DHCP, hosts Synology VPN Plus, Manages dhcp reservations (static IP addresses for all my local devices)) --LAN CONNECTION to Hue bridge, Tado Bridge, TPLink Powerline Adapter-- 2nd TPLink Powerline Adapter connects via LAN to my main Raspberry Pi (hosts Homebridge and AirPlay Server). All the rest (TV, ATV4, iOS/macOS devices etc) are connected via wifi. My 2nd raspberryPi with Pi-Hole is also connected via wifi right now.

All devices have static IP's, so within the network, I can connect to them with the IP Address or the device name etc.

Everything is stable and just works fine.

Now I set up Pi-Hole on my 2nd Pi. I am using OpenDNS for blocking ads on Pi-Hole.

And here comes my issue: If I manually add the DNS on my iPhone, Mac or iPad of my PI, nothing changes, I still see ads on youtube or on websites.
I then thought of using the PI as the main DNS network wide with adding it as the primary one on my Synology Router.

If I add the IP address of the PI under in my network center under the tab Internet DNS server, I can no longer open ANY website, they just load to nowhere. If I add the IP in the local network section ad the primary DNS server, I can open websites, but still with ads.

My network knowledge is very basic, so I am not sure how to proceed.

Please generate a debug log from your Pi-Hole, upload it and post the token here.

[✓] Your debug token is: hc50tpo31i

No update so far, or was any mod able to see where the issue is?

You're going to want to disable:

“Improve protection against cross-site request forgery attacks” under Network Center - Security

This will prevent your Synolgy router to intercept/re-route packets on port 53 and everything should work as expected.

I tried that out, but still the same issue. If I disable that option and add the DNS of pihole into the network settings, I can no longer open any website. But whats really strange is, that it does not change the dns on my devices, they still show me the "old" one from my synology router. A new lease or even forgetting the network and completely reconnect to it does not solve the issue. It only changes the dns if I add it into the local network section. So I guess the issue is, that it does not distribute the changes of the internet section to my clients... so I am not sure if this is still within your scope, or now clearly an issue with my synology router and I should ask the question on a synology forum?

You would need to add the Pi-hole IP under the WAN settings.
Also set your Pi-hole to " Listen only on interface wlan0 in Listen on all interfaces, permit all origins" under listening mode on the /admin/ page.

@Radu_D might have some more details on this, as he has a Synology router too, and he had the exact same issue.


Never add the Pi-Hole's IP address on "Network Center - Internet" section, this will break your connection.
Always add the IP on "Network Center - Local network" section as your primary DNS and leave the secondary DNS blank. "Forward known DNS server" disabled.
Also, you can try checking on Package Center and disable the package named "Safe Access". I personally have it enabled (on my RT2600AC) and it works ok, but you never know.

1 Like

@Radu_D @RamSet thanks for your help. A short test on my iPad and iPhone shows, that websites are not showing any ads, even with my usual adblocker disabled. Whoop whoop! Thanks a lot! If I have any further issues or questions I will raise a new thread, so I guess this one can be closed?! If needed.

1 Like

A post was split to a new topic: Synology setup help

Radu_D can you help me please? I have a very similar setup (Cable modem, RT2600ac in bridge mode, Pi-hole on a wired RPi3B). Pi-hole only works if I add RPi's IP in "Network Center - Internet" section, and add the router's IP under "Network center - Local Network", also I can not see the individual clients on the Pi-hole dashboard. Can you (or someone) help me with the correct configuration you have?