I'm going to apologise if this has already been talked about, but I haven't been able to fix this based on my searches so far.
Getting a DNS server failure in the Pi hole when I log in to the browser interface. No other errors in the browser interface. Updated gravity. Ran the pihole -d command. Running under the assumption that it was a port 53 issue, I tried disabling and stopping dnsmasq, but the response I get is...
Your debug log shows that a few days ago (September 29) Pi-hole was starting correctly:
2026-09-29 22:01:07.963 EDT [1448M] INFO: PID of FTL process: 1448
2026-09-29 22:01:08.006 EDT [1448M] INFO: listening on 0.0.0.0 port 53
2026-09-29 22:01:08.006 EDT [1448M] INFO: listening on :: port 53
It also shows that the current issue is really caused by port 53 already in use:
2026-10-02 18:40:47.647 EDT [4964M] INFO: PID of FTL process: 4964
2026-10-02 18:40:47.649 EDT [4964M] CRIT: Error in dnsmasq configuration: failed to create listening socket for port 53: Address in use
But the port diagnostic shows Pi-hole using the UDP port 53 (but no TCP port) and a dnsmasq instance using port 53 for a different IP:
*** [ DIAGNOSING ]: Ports in use
(...)
[✓] udp:0.0.0.0:53 is in use by pihole-FTL
(...)
[✗] udp:10.12.194.1:53 is in use by dnsmasq
(...)
[✗] tcp:10.12.194.1:53 is in use by dnsmasq
(...)
Try these commands to stop dnsmasq again and restart Pi-hole: