DNS resolving but Pi-hole not doing it


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pi hole should block ad domains based on the blacklists

Actual Behaviour:

Ads are not blocked, all sites resolve dns.

Debug Token:

rxejj7muve

Looking around the forum I think this might be an issue with my DNSmasque but that gets a checkmark on the debugging from the pi-hole, so now I don’t know what to think

I know my router is using the pi hole as the dns resolver, and every system that I run an ipconfig or an isconfig on shows that the correct ip address is the dns for that device, and I have the blacklists installed as i have 132,000 domains there, but there are no queries to the pi-hole itself, they all seem to be resolving somehow.

note that I am running this on an ubuntu server.

I have searched and searched but none of the solutions I have found have seemed to solve this issue.


#2

On the Pi-hole device can you run the following commands:

sudo systemctl status --full --no-pager dnsmasq.service
cat /etc/resolv.conf

The debug log shows that dnsmasq is not running on the Pi-hole device, but there is a resolver running. dig queries to 127.0.0.1 fail but queries to 192.168.0.2 return an answer.


#3


#4

dnsmasq could not start because there is another DNS resolver in operation. What is the output from sudo ss tlpn | grep 53?


#5

Error: an inet prefix is expected rather than “tlpn”
Cannot parse dst/src address


#6

Sorry, I left off the -, try sudo ss -tlpnax | grep 53 instead.


#7

I think this is all of it:


#8

That shows that systemd-resolved and named have control over port 53 on your system. @RamSet What was the process of clearing out systemd-resolved from having control?


#9

Would this work, do you think?

sudo systemctl disable systemd-resolved.service
sudo service systemd-resolved stop


#10

Found it :slightly_smiling_face:

edit /etc/systemd/resolved.conf and add this line:

DNSStubListener=no
This will switch off binding to port 53.

Restarted the system and all is good!

Thanks very much for your help @DanSchaper


#11

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.