DNS Requests not routed to pihole unless manually specified

Expected Behaviour:

Installed pihole mostly following linustechtip forum's guide. Have not attempted DNS Over HTTPS or Unbound, whichever may be better. Have placed DNS 1 with pihole's IP (DHCP Resevervation) and DNS 2 with Putting DNS1 and 2 as the same does not allow access to Internet, neither does putting in a dummy DNS for DNS2.
-OS: Raspbian GNU/Linux 10 (buster)
-Hardware: Raspberry Pi Zero W Rev 1.1 (Pihole connected via wlan0)

-Router: Myrepublic WiFi Halo (Fast 5366) Sagemcom

Actual Behaviour:

Internet not routed through pihole automatically. Could it be my router's limitation? If so I will have no choice but to manually point my devices' DNS manually. Could my router's network setting be the issue? The screenshot's from my router's Device Info> General tab:


Debug Token:

Link to debug token here.

Your debug log is normal. Your Pi-hole is at this IP:


The router DNS settings are pointing to different IP's.

So you are saying my router has a "hardcoded" DNS setting, and thus their Manual DNS changing option that I did under Internet Connectivity in the router has possibly limited effects? Is that why when I set DNS on say my mobile to rout to pihole, then I'm able to see pihole picking up and blocking traffic?


Same screenshot in the reddit post I first asked for help from, but I have not made changes so far.

I did not say that. I observed that your screen capture of your settings shows that Pi-hole is not one of the assigned DNS servers.

What would that mean though? Before I had the pi I simply used for DNS1 and for DNS 2. Now that I simply changed DNS1, internet would no longer be accessible. The 1st screenshot confuses me though (Device Info> General tab:) since it never reflects the DNS I've manually inputted. Is it possible there is uh, some kind of conflict between what I've manually inputted, and what the router displays?

EDIT: I don't like it, but I will ask my ISP about my router to see if they can help.

ISP has not replied back to me. If any one else has other suggestions do let me know.

ISP has replied saying: "Hi , We recommend you to assign the PiHole DNS server manually on your devices instead instead of assigning it to the WIFI HALO router ."

So looks like that's my only way. Now I'm looking into speeding up Unbound, or consider DNS over HTTPS if things still don't work out well for me.

Yep, looks like I will be doing Step 3, thank you.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.