Dns_probe_finished_nxdomain

#1

Hi,
I’m having some trouble with for example korben.info domain which give me a DNS_PROBE_FINISHED_NXDOMAIN.
The outpuf of dig is :
dig korben.info

; <<>> DiG 9.9.5-9+deb8u10-Debian <<>> korben.info
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 5898
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags: do; udp: 512
;; QUESTION SECTION:
;korben.info. IN A

;; Query time: 73 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Mar 28 12:05:43 CEST 2017
;; MSG SIZE rcvd: 40

I’m using google DNS.

#2

Did you run that on the Pi-hole? Run pihole -d for a debug token.

#3

The token is : 203puogbir

#4

The debug log shows that everything seems to be working normally. What machine did you run that original dig command on?

#5

on the pi itself and my other computers can’t access this website

#6

it’s the same dig response on another computer :
; <<>> DiG 9.8.3-P1 <<>> korben.info
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 14675
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;korben.info. IN A

;; Query time: 48 msec
;; SERVER: 192.168.1.5#53(192.168.1.5)
;; WHEN: Tue Mar 28 18:26:50 2017
;; MSG SIZE rcvd: 29

#7

If I disable DNSSEC, it works again… strange
; <<>> DiG 9.8.3-P1 <<>> korben.info
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43259
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;korben.info. IN A

;; ANSWER SECTION:
korben.info. 218 IN A 104.25.119.12
korben.info. 218 IN A 104.25.118.12

;; Query time: 7 msec
;; SERVER: 192.168.1.5#53(192.168.1.5)
;; WHEN: Tue Mar 28 18:40:44 2017
;; MSG SIZE rcvd: 61

#8

Try these on the Pi and other computers:

nslookup doubleclick.com
nslookup google.com
#9

On some versions of dnsmasq, DNSSEC doesn’t work correctly.

#10

nslookup doubleclick.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: doubleclick.com
Address: 192.168.1.5

nslookup google.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Non-authoritative answer:
Name: google.com
Address: 216.58.201.238

#11

Ok if not reliable I will simply disable it

#12

There are some threads that show how to update dnsmasq to support DNSSEC, but it’s definitely not necessary.

#13

Thanks for all these answers

#14

Sometimes when you try to open the browser you get the dns_probe_finished_nxdomain error where the webpage is not available. This error occurs when DNS fails to translate. The easiest way to solve this problem on Google Chrome as well as all the other browsers is just follow the simple steps: 1. Alter the DNS IP Address 2. Flushing the DNS 3. Restarting the DNS Client 4. Resolving the ‘dns_probe_finished_nxdomain’ error in Android.

#16

first of all, do the basic like clear cache and cookies, reset the browser,
disable your 3rd party anti-virus and flushing dns.

if it doesn’t work you may try this steps that I’m using to sort out this problem it actually works for me…
Solution No.3. Configure your DNS Address add to open on this website following the guides with picture of course.

#17

Apply the below given steps to fix DNS_PROBE_FINISHED_NXDOMAIN Error

Method 1: Flushing the DNS
Method 2: Changing DNS settings
Method 3: Reset all Features to Default

Source: http://www.pcerror-fix.com/tricks-repair-dns_probe_finished_nxdomain-error-google-chrome-windows-10

#18

The DNS_PROBE_FINISHED_NXDOMAIN error is very common.

Before panicking clear the cache and cookies of your browser.

If that doesn’t work then maybe you need to try out some advanced methods.

Restart DNS Client service: This is the method that worked for me and helped.

I read this article: https://www.gadgetarmy.com/dns_probe_finished_nxdomain-error/

Solution number 2 from the above article to be precise. Let me know if the issue is resolved or not.

Cheers!

#19

Is there any permanent solution for this DNS_PROBE_FINISHED_NXDOMAIN error? I often find it and somehow I manage to fix it but after few days it starts appearing again. Can’t figure out to get rid from it forever.

#20

Forever I can’t promise.

It is negative caching what keeps the ‘wrong’ result in the cache of the clients.

If you want to solve it you have change the TTL value from what the authorised DNS server states, to a lower value or even no TTL.

https://github.com/pi-hole/pi-hole/issues/1794

https://github.com/pi-hole/pi-hole/blob/6eedfb572e474e7a88f8dc6526ffee7ff8979559/advanced/dnsmasq.conf.original#L541

On which version of Pi-hole are you on the moment. There are made a lot of improvements lately and a important one is a better DNSSEC implementation since version 4.2x

#21

This tread is very much helpful.thank u everyone.i feel extremely grateful to be a part of this community. Thank you for being this kind and warm welcome.

1 Like