DNS breaks when installing Pihole

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pihole installs and starts acting as a DNS adblocking server

Actual Behaviour:

When Pihole is installed on a fresh install of sketch, all of the DNS fails to resolve. Before pihole is installed on the pi, I am able to ping websites. After pihole is installed i am unable to resolve DNS and it also looks like pihole isnt even installed as it fails to get to the FTL? (not sure what the FTL is) i am unable to run any commands or access the website as (Bash: Pihole: is not a command) or something along those lines
I should also add, when i was going through everything that comes up when installing pihole i noticed that it failed to run as root or something like that, so i did (sudo su) and ran the command as root (on a fresh install) and everything went fine... until the FTL bit at the end.

Debug Token:

Unable to generate a debug token as explained in the ##actual behaviour section

Try this to get Pi-Hole installed - first we reset the nameserver on the Pi, then attempt a re-install.

sudo nano /etc/resolv.conf

edit nameserver to nameserver or your preferred third party DNS service, save and exit

Run curl -sSL https://install.pi-hole.net | bash

If the installer does not complete, then post the output of the installer.

FTL is essentially the engine of Pi-Hole, the software that does the resolving.


Sorry for the late reply, so i "installed" pihole and it failed again... now how do i show you the log?
EDIT So i did the sudo nano /etc/resolv.conf and it says

"#Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
search localdomain"

Edit 2 Going to try and run it as root
Edit 3 Ran the command as root and still nothing FTL couldnt start and when i try to do anything with the pihole command nothing... Will provide log as soon as i know how to provide it

The output of the installer appeared as an output on your terminal screen. Copy and paste that output in a reply here.

After you installed Stretch, did you run the OS updaters and if so, were they completed?

sudo apt update

sudo apt upgrade

root@raspberrypi:~# curl -sSL https://install.pi-hole.net | bash
stty: 'standard input': Inappropriate ioctl for device

[βœ“] Root user check

     :cccclll:.      ..,,
      :ccccclll.   ;ooodc
       'ccll:;ll .oooodc
             .. ','.
    .........  ....  .........
    ..........      ..........
    ..........      ..........
    .........  ....  .........

[βœ“] Disk space check
[βœ“] Update local cache of available packages

[βœ“] Checking apt-get for upgraded packages... up to date!

[i] Installer Dependency checks...
[βœ“] Checking for apt-utils
[i] Checking for dialog (will be installed)
[βœ“] Checking for debconf
[βœ“] Checking for dhcpcd5
[βœ“] Checking for git
[βœ“] Checking for iproute2
[βœ“] Checking for whiptail
[i] Using interface: eth0
[i] Using Google DNS servers
[βœ“] Set IP address to
You may need to restart after the install is complete
[i] IPv4 address:
[i] IPv6 address:
[i] Web Interface On
[i] Web Server On
[i] Logging On.
[βœ—] Check for existing repository in /etc/.pihole
[βœ“] Clone https://github.com/pi-hole/pi-hole.git into /etc/.pihole

[βœ—] Check for existing repository in /var/www/html/admin
[βœ“] Clone https://github.com/pi-hole/AdminLTE.git into /var/www/html/admin

[i] Main Dependency checks...
[βœ“] Checking for cron
[βœ“] Checking for curl
[i] Checking for dnsutils (will be installed)
[βœ“] Checking for iputils-ping
[i] Checking for lsof (will be installed)
[i] Checking for netcat (will be installed)
[βœ“] Checking for psmisc
[βœ“] Checking for sudo
[βœ“] Checking for unzip
[βœ“] Checking for wget
[i] Checking for idn2 (will be installed)
[i] Checking for sqlite3 (will be installed)
[βœ“] Checking for libcap2-bin
[i] Checking for dns-root-data (will be installed)
[i] Checking for resolvconf (will be installed)
[βœ“] Checking for libcap2
[i] Checking for lighttpd (will be installed)
[i] Checking for php-common (will be installed)
[i] Checking for php-cgi (will be installed)
[i] Checking for php-sqlite3 (will be installed)
[βœ“] Enabling lighttpd service to start on reboot...

[i] FTL Checks...

[βœ“] Detected ARM-hf architecture (armv7+)
[i] Checking for existing FTL binary...
[βœ—] Downloading and Installing FTL
Error: Unable to get latest release location from GitHub
[βœ—] FTL Engine not installed

Sorry forgot to add that was with everything updated and installed and that was with the previous suggestion you made as well

What is the output of this command?

curl -sI https://github.com/pi-hole/FTL/releases/latest
HTTP/1.1 302 Found

Server: GitHub.com

Date: Wed, 13 Mar 2019 02:26:13 GMT

Content-Type: text/html; charset=utf-8

Status: 302 Found

Vary: X-PJAX

Location: https://github.com/pi-hole/FTL/releases/tag/v4.2.3

Cache-Control: no-cache

Set-Cookie: has_recent_activity=1; path=/; expires=Wed, 13 Mar 2019 03:26:13 -0000

Set-Cookie: logged_in=no; domain=.github.com; path=/; expires=Sun, 13 Mar 2039 02:26:13 -0000; secure; HttpOnly

Set-Cookie: _gh_sess=RVYwT3VvMitRbS9DSGVtRXhSL2JVSWx0aFVQTmxydlQ2b3p4VmpnNjRUUHJ6VWRMenVubHFMbGhURHZjWmx3dlc4TGg4Q3ZqNE96bXhQd2VSK2NWVCtqYWNodjg4Y3pDZTY4VmsvYU5RcHlJc3RVNWdESXJ5dm01a3BpVERyVGNUd3U4OUJUNG9SNGt5UTdBK24rR2U0ZUpYTG5NQkZwMDA4bjk5VVd6QVZhemljUnByWk5pMVR5RGwyOFhySkZILS0zamNmUTRtY3oxa09lMWxwOWY2MDhRPT0%3D--1e21b4eb2a8da04749321bfd44ae9a4af83dbe7a; path=/; secure; HttpOnly

X-Request-Id: 1ed03ab8-efef-451b-9015-9efe9e401781

Strict-Transport-Security: max-age=31536000; includeSubdomains; preload

X-Frame-Options: deny

X-Content-Type-Options: nosniff

X-XSS-Protection: 1; mode=block

Expect-CT: max-age=2592000, report-uri="https://api.github.com/_private/browser/errors"

Content-Security-Policy: default-src 'none'; base-uri 'self'; block-all-mixed-content; connect-src 'self' uploads.github.com www.githubstatus.com collector.githubapp.com api.github.com www.google-analytics.com github-cloud.s3.amazonaws.com github-production-repository-file-5c1aeb.s3.amazonaws.com github-production-upload-manifest-file-7fdce7.s3.amazonaws.com github-production-user-asset-6210df.s3.amazonaws.com wss://live.github.com; font-src github.githubassets.com; form-action 'self' github.com gist.github.com; frame-ancestors 'none'; frame-src render.githubusercontent.com; img-src 'self' data: github.githubassets.com identicons.github.com collector.githubapp.com github-cloud.s3.amazonaws.com *.githubusercontent.com; manifest-src 'self'; media-src 'none'; script-src github.githubassets.com; style-src 'unsafe-inline' github.githubassets.com

X-GitHub-Request-Id: F811:499D:5450C:A4ECC:5C886A45

What is the output of these commands (this will run the installer with verbose logging):

wget -O basic-install.sh https://install.pi-hole.net
sudo bash -x basic-install.sh

Ill put it here as its 16 pages long... pi@raspberrypi:~ $ wget -O basic-install.sh https://install.pi-hole.net--2019- - Pastebin.com
But long story short its still doing the same thing

What is the output of this command?

curl -sI https://github.com/pi-hole/FTL/releases/latest | grep Location | awk -F / '{print $NF}'

This has happened to me multiple times on a Pi 3+ running updated Raspbian (full), and once on an up-to-date Lubuntu instance. As an added kicker, the uninstaller dies as soon as it tries to uninstall a dependency (any dependency, as far as I can tell), so it's rather difficult for a newbie like me to untangle the knot.

Output of curl -sI https://github.com/pi-hole/FTL/releases/latest | grep Location | awk -F / '{print $NF}'
is v4.2.3.

The installer consistently hangs in both installs and updates at the FTL stage. At various points I've gotten a failure to download FTL (as if it were a network issue), an actual download error citing a checksum issue, or the simple "Error: Unable to get latest release location from GitHub" noted above.

I'm happy to respond nightly if I can help the community get this figured out. I'd really like to get it up and running again.

When having the issue again, I'd suggest opening a new thread and post a token for the devs to have a look:

If you have specific errors, post as much output/info here for the others to have a look.
And there are many topics bout that error with solutions if you search:


EDIT: Ohw and welcome :wink:

So i did as Mcat12 said and i only got "v4.2.3" was that correct?

Try run below one everytime before you run the Pi-hole installer or pihole -r to repair or reconfigure:

echo 'nameserver' | sudo tee /etc/resolv.conf

It changes DNS nameserver to be used to that of Google's temporarily until fixed.
Why the two identities ?

Ok so now it has been installed and it seems to be functioning perfectly, the line that @deHakkelaar mentioned really helped as it set my pi back to being able to access the web and i didnt have to keep flashing the sd card, after running the command a couple times it worked and installed, i ran the curl -sSL command, and it didnt like that so i did the wget -O command and it installed perfectly that time, I have made a debug token through pihole -d if that helps you but I am unsure if that helps you or not. Regardless thank you for the help and the patience from all of you. :smiley:

1 Like

One more thing since i have this open, when entering pihole -t i see a line "failed to load names from /etc/pihole/black.list: No such file or directory. Any idea what that means?

That is a message that you don't need to worrry about. This file does not exist in all installations (i.e. you haven't added any entries in your local blacklist).

Ok, just curious because it doesnt seem to be blocking ads... guess it just needs a minute to get things sorted?

That error won't affect ad-blocking. If your Pi-Hole isn't blocking ads, this is not the problem.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.