DLNA service

Hi, Friends!

I'm having difficult times trying to set a DLNA server in my local network and I'm starting to think pi-hole has an role in this problem.

Pi-hole is running on a raspberry pi, that's where I would like to put minidlna too. It runs the network DHCP (alone, of course). But after setup, minidlna service runs fine. The problem is no other device can discover the DLNA server - it only can be seen by the local host.

I've tried installing minidlna on two another machines (both Debian Bullseye), but get the same result.

On that raspberry I also run a VPN wireguard server, just like pi-hole wiki teaches, in order to access DNS from outside.

Is there, in any way, a chance that pi-hole's configuration could be blocking those packages, interfering or causing this malfunction?

Thanks in advance

It's very unlikely that Pi-hole is involved in this

Did you configure the firewall to allow ports as required by miniDLNA?

I think the firewall ports are open. Just installed firewalld for that purpose and enabled minidlna specific settings.