Display all clients in Top List Clients


#1

Expected Behaviour:

Display all LAN clients in Top List Clients

Actual Behaviour:

Only the following clients are displayed: 192.168.1.1, localhost, <FQHN_Pi-Hole>

I installed Pi-hole in LXC in a dedicated network segment 192.168.100.0/24 (VLAN).
All clients are running in LAN 192.168.1.0/24 and connected to Fritz!Box.
This Fritz!Box with IP 192.168.1.1 runs as router and DHCP.
In the Fritz!Box’s DHCP settings the DNS server is set to 192.168.1.1; in the Fritz!Box’s internet settings the DNS server is the Pi-hole (static) IP 192.168.100.101.

DNS is working as expected.
However I get no LAN clients displayed in Pi-hole’s Top List Clients.

Question:
What are the requirements to get all LAN clients in Pi-hole’s Top List Clients?
Must I configure DHCP in Pi-hole?

THX


#2

You can try the conditional forwarding option in Pi-Hole. From the web admin interface (Settings > DNS), see the section on Conditional forwarding at the bottom of the page.

Note that this does not solve your problem in all network configurations. If it does not, then the next option would be to use the Pi-Hole as DHCP server (which has some benefits as discussed here):


#3

I’ve enabled “Conditional Forwarding” already, but this is not solving the issue.


#4

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.