Disable SSL Apache vhost


#1

Hi,
is there a way to do that “enabling-https-for-your-pi-hole-web-interface” with apache?

I’ve already run apache for other use than pihole and all works fine.
Now I’ve tried to deactiviate ssl for the default vhost (the ad-sites), but if I deactiviate ssl on this vhost, it deactiviates it for all vhosts. So I can’t use SSL for domain1-3.com anymore.
Thats strange because SNI generally works.
I use Ubuntu 14.04 with Apache/2.4.7

ports.conf:

  Listen 80

<IfModule mod_ssl.c>
    Listen 443
</IfModule>

ssl.conf:

<VirtualHost *:443>
        SSLEngine off
</VirtualHost>

<VirtualHost *:443>
        ServerName domain1.com

        SSLEngine on
        SSLCertificateFile /etc/ssl/certs/apache.crt
        SSLCertificateKeyFile /etc/ssl/private/apache.key
</VirtualHost>

<VirtualHost *:443>
        ServerName domain2.com
        ServerAlias domain3.com

        SSLEngine on     
        SSLCertificateFile /etc/ssl/certs/apache2.crt
        SSLCertificateKeyFile /etc/ssl/private/apache.key
</VirtualHost>

So with this config ssl is generally disabled.
Does anyone have any ideas what I’m doing wrong?
Thanks!