Difficulties setting up router to work with Pi-Hole


#1

A much more detailed description was posted on reddit!

Expected Behaviour:

Advertisements should be blocked. I should be able to set the router DHCP to the pi-hole’s rpi’s ip. Alternatively set an individual device to “connect through the pi-hole”.

Actual Behaviour:

Advertisements are not blocked. I can’t find where and how to set the router DHCP to the pi-hole’s rpi’s ip. Nor can I set the correct configurations on any of my devices.

Debug Token:

oizzjq4d72

Thanks

Many of them. In advance…!


#2

You may find these threads helpful.


#4

OK, I’ve input the pi hole’s rpi’s ip in the wrong field. For those following this, you should put it in the Additional DNS servers rather than anywhere else (I was putting it in the Additional static addresses).

Thanks @jfb!


#5

Although, I’ll add that I still couldn’t set the router’s dns to that of the pihole, so I’m solving this by setting each device individually…


#6

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.