Didn't work


#1

Please delete ------- thanks


#2

It doesn’t look like you should put an IP in the Local Domain box. Is there no setting which mentions DNS?


#4

Preferred is to have your router assign only one DNS server (the Pi-hole IP address) to your clients via the router DHCP service.
You can check DNS server(s) assigned to Windows clients with below one in a CMD box:

ipconfig /all

Or if on a Linux client:

cat /etc/resolv.conf

Looking at screenshots from your router, it looks like this router is lacking necessary DHCP–>DNS settings to do this.
Pi-hole to the rescue … Pi-hole can take over this DHCP task and push the right DNS server to its clients.
You just disable the DHCP service on the router, probably with the “IP Address Distribution” setting, and as a replacement, enable the DHCP service on Pi-hole:


#6

Why not just try.
On the clients, you need to renew their DHCP lease by either disconnecting & reconnecting network on the clients or reboot them.
Afterwards, you can check on clients with: