Dashboard Indicates ads are being blocked, but I am still seeing every ad possible

Expected Behaviour:

Simple blocking of ads from the generic blacklist on all devices connected to my router (windows pc, iphone, roku boxes). No frills.

Actual Behaviour:

No ads blocked on any device including the pi-holed raspberry pi.

Debug Token:

https://tricorder.pi-hole.net/wpbtq9poyr

Obligatory details:

  • I just set this up today for the first time and it has never truly worked. I always try to do my due diligence before seeking assistance, but couldn't find someone with a replicated problem.
  • My DNS is configured to route through the Pihole both on the router and on my individual device (windows laptop in this case)
  • I disabled DHCP on the router and enabled it on the Pihole
  • I locked my ipaddress for the pihole to 192.168.1.27

My ipconfig /all displays the following for my WLAN
Connection-specific DNS Suffix . : lan
Description . . . . . . . . . . . : Intel(R) Wi-Fi 6 AX200 160MHz
Physical Address. . . . . . . . . : 78-2B-46-29-5B-F3
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::dc2d:2897:44b8:ea7c%10(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.213(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, June 10, 2021 10:21:57 PM
Lease Expires . . . . . . . . . . : Friday, June 11, 2021 10:50:49 PM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.27
DHCPv6 IAID . . . . . . . . . . . : 108538694
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-27-79-1C-FD-8C-8C-AA-53-12-83
DNS Servers . . . . . . . . . . . : 192.168.1.27
NetBIOS over Tcpip. . . . . . . . : Enabled

nslookup pi.hole returns the following:
Server: raspberrypi
Address: 192.168.1.27

Name: pi.hole
Address: 192.168.1.27

nslookup doubleclick.com returns the following:
Server: raspberrypi
Address: 192.168.1.27

Name: doubleclick.com
Addresses: ::
0.0.0.0

The system believes it's blocking ads for me as indicated by the dashboard traffic, and it is certainly seeing the traffic in the debug log, but as seen at Can You Block It, I cannot. :frowning:


Help would be greatly appreciated.

I'm only making a guess here but did you enable IPv6 ad blocking?

Your debug log shows Pi-hole to be fully operational, with full IPv4 connectivity.
It is receiving and filtering DNS traffic:

*** [ DIAGNOSING ]: contents of /var/log
-rw-r--r-- 1 pihole pihole 48483 Jun 10 23:04 /var/log/pihole-FTL.log

   -----tail of pihole-FTL.log------
   [2021-06-10 22:26:24.963 616M] Imported 3713 queries from the long-term database
   [2021-06-10 22:26:24.963 616M]  -> Total DNS queries: 3713
   [2021-06-10 22:26:24.964 616M]  -> Cached DNS queries: 595
   [2021-06-10 22:26:24.964 616M]  -> Forwarded DNS queries: 2668
   [2021-06-10 22:26:24.964 616M]  -> Blocked DNS queries: 429
   [2021-06-10 22:26:24.964 616M]  -> Unknown DNS queries: 7
   [2021-06-10 22:26:24.964 616M]  -> Unique domains: 620
   [2021-06-10 22:26:24.964 616M]  -> Unique clients: 12
   [2021-06-10 22:26:24.964 616M]  -> Known forward destinations: 2

Client browsers may still by-pass Pi-hole when they are configured to use DNS-over-HTTPS (DoH).

Verify that DoH is disabled in your browsers.

This is a specific test site that may contain elements you cannot block with Pi-hole.

Do you see ads in daily browsing? A sure test is to go to cnn.com, and if the site is not crawling with ads, your Pi-hole is working properly with your clients.

Without Pi-hole:

With Pi-hole:

IPv6 blocking should not be necessary if I disable IPv6 on my device or router, correct? Additionally, I should still blocking ads that are distributed via IPv4.

I've disabled IPv6, and the problem persists.

I explicitly disabled DoH but it didn't change anything. Thank you, though, it was a good suggestion.

Thanks jfb, it seems my solution is that I was looking at sites that had ads that are not on the blacklist by default. :sweat: My apologies for not being more diligent in my research, and thanks for clarifying!