Dashboard/FTL offline although no errors?

Hi guys,

As already many members had this kind of issue, it appears also for me. I have read and tried already many times the proposed solutions, even reinstalled everything from scratch and still I cannot get it working.

I am running Ubuntu 20.04 LTS (arm64). (Was thinking to switch to Debian... perhaps better?)

I do not see where the problem might be. Can everybody take a look on it?

Debug: 7rszr06qyo

Many thanks and regards,

What I have changed since installing Pi-hole:

You're running nginx as webserver which is unsupported (only lighttpd is). Search the forum how to get it working with PI-hole

[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)

*** [ DIAGNOSING ]: lighttpd version
[✗] lighttpd version could not be detected.


Well, even lighttpd gave the same "FTL offline" issue thus the switch to nginx.
My impression was that the data cannot be fetched - however I gave the right permissions.

I removed nginx and switched back to lighttpd and having same problem.

I created a new token: 6o84jg046l

Any idea?

Can you describe your problem in a bit more detail, please? Is the whole dashboard not working? Only a part? From your log, FTL is reported as not running, but in fact it looks like it is and was

*** [ DIAGNOSING ]: Ports in use
*:5023 telnetd (IPv6)
*:5080 httpd (IPv6)
*:22 sshd (IPv4)
*:22 sshd (IPv6)
[80] is in use by lighttpd
[80] is in use by lighttpd
[53] is in use by pihole-FTL
[53] is in use by pihole-FTL
[4711] is in use by pihole-FTL
[4711] is in use by pihole-FTL

*** [ DIAGNOSING ]: Pi-hole processes
[✗] lighttpd daemon is 
[✗] pihole-FTL daemon is 

   [2021-07-16 22:42:39.641 29610M] Imported 1691 queries from the long-term database
   [2021-07-16 22:42:39.641 29610M]  -> Total DNS queries: 1691
   [2021-07-16 22:42:39.641 29610M]  -> Cached DNS queries: 591
   [2021-07-16 22:42:39.641 29610M]  -> Forwarded DNS queries: 913
   [2021-07-16 22:42:39.641 29610M]  -> Blocked DNS queries: 182
   [2021-07-16 22:42:39.641 29610M]  -> Unknown DNS queries: 0
   [2021-07-16 22:42:39.641 29610M]  -> Unique domains: 397
   [2021-07-16 22:42:39.641 29610M]  -> Unique clients: 6
   [2021-07-16 22:42:39.641 29610M]  -> Known forward destinations: 6

Sorry for my late reply, I have been on a short holiday in the meanwhile.

Exactly! The interesting part is that pihole runs in the background, however the Dashboard does not load. I could change and save settings, refresh Gravity, update lists, but the statistics/logs are not shown (loads for eternity). I had the impression it cannot fetch the data from the db. Also, the pihole page shows that FTL is offline.

Well, let me give you a short overview about the system as it is not a standard thing:

  • Hardware: Samsung Galaxy S10 rooted (with Magisk)
  • Software: Android 11
  • on top of Android is 'Linux Deploy by meefik' installed
  • with 'Linux Deploy' I have set up an Ubuntu Linux 20.04 (also tried with Debian)

So far as I know, Linux Deploy uses containers to deploy linux. What I could figure out so far, it is always deployed in a chroot environment and therefore some commands in the pihole installations are performed but "ignored requests".

I have set up an Ubuntu VM on my laptop and deployed pihole on it, worked like a charm on the first snap. I will further troubleshoot with the above configuration and try to get it running, will see...

This is a configuration way out of the usual supported devices/OS. I would be surprised if it is working without any issues instead of the other way round. I read some others tried to get Pi-hole running on Android, but I'm not sure if they have been successful. Use the search function.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.