Correct Unbound IP values?

Hi, after installing Unbound as per; unbound - Pi-hole documentation under "Disable resolvconf for unbound (optional)" are these the correct values in:

interface eth0
static ip_address=
static routers=
static domain_name_servers=



I know neither your network nor your requirements or intentions, so I can't judge whether those settings are correct. Only you can know whether those settings would match your requirements.

However, I don't see how unbound would or should be involved here at all, so I may not fully understand your question. When you followed our guide, unbound would be used as Pi-hole's sole upstream, and you do not show that configuration here.

Are those DNS servers in your resolv.conf the ones that you want that machine to use?
Then they are correct.

Do you want that specific machine to use Pi-hole for DNS instead?
Then you may want to add the loopback address as static DNS server in dhcpcd.conf, probably together with a public DNS server as a second entry.

Did that machine pick up those DNS servers in resolv.conf through a router's DHCP server?
Then you probably may want to consider configuring your router to instead distribute Pi-hole via DHCP.

I have a static IP from my ISP, the router is After I installed the Raspberry OS (IP, I set and in /etc/resolv.conf, updated the OS. Then I installed Pi-hole on my Raspberry, then Unbound. I followed the guide. After I was done installing Unbound I checked /etc/dhcpcd.conf and no value for static domain_name_servers= and /etc/resolv.conf showed and It said in the guide I should check that the IPs in /etc/resolv.conf reflects the /etc/dhcpcd.conf, hence my question.

I have 20 devices on my network, I disabled DHCP on my router and activated DHCP in Pi-hole. I set Static DHCP leases configuration in Pi-hole inputting MACa, IPa and Hostnames manually ranging from and upwards.

I want Pi-hole to handle all DNS requests with Unbound on Raspberry as upstream.

When I set and in both /etc/resolv.conf and /etc/dhcpcd.conf it looks like I am using Cloudflare as my DNS servers. When I have it as is, looks like my static IP is my DNS server. When I set in both, looks like my static IP is my DNS server.

Hope that helps.

Your question is:
Correct Unbound IP values?

My answer to that was:

Our guide details to Configure Pi-hole to set as Pi-hole's sole DNS server.

If you've done that, then you've set the correct unbound IP values for a bare metal Pi-hole.

If that doesn't quite tackle your issue, please rephrase your question.

All good, thanks