Console slow, only for Pi-hole clients

I just re-kicked my Raspi and installed the latest Pi-hole. The admin console is very slow when accessed from a machine which uses Pi-hole, but is quick when accessed from other machines.

My first thought was the reverse DNS lookup was slow (something misconfigured). Doing a DNS lookup separately on the same device, takes 112 ms. I also compared the related
DNS ettings on an image of the old installation and changing them didn't help.
I don't see any errors in the logs (other than two which the forum says are ok).

Any ideas? Thanks

Please upload a debug log and post just the token that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

Thank you
j1ycgs1crz

A twist to this... On my Android (Pixel 3A) the console is slow if the Pi-hole is the DNS (only). On a PC it's fast, even if the Pi-hole is the DNS.

Thanks

pihole -dThis text will be blurred

I included the token above. I need to see when I have a bit more time to look at this in more depth.

This may be related to my router. If I have the router set the DNS to Pi Hole via DHCP, then public websites are fast, but the console, a private IP, is slow. If I manually set the DNS to Pi Hole on my Android, then the console is fast, but public websites are very slow.

Thanks

Ok, yes, so that I could send only my phone to Pi Hole, from my Mikrotik router, someone suggested creating a separate dhcp network. As such, this network only contains this one IP, my cellphone. The netmask is 255.255.255.255. I need to find another way of doing this, but that's not a Pi Hole issue.
Thanks!

I got rid of the other DHCP network on the router and all is fine now (after I manually set the DNS on my Android phone.)