Connecting via VPN - Not blocking any adds


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Ads to be blocked.

Actual Behaviour:

I can easily remote into the Pi remotely via VPN and I can access all services on my pi, including Pi-Hole, Plex and others; however, when I review the activity on my pi, nothing is being blocked. When I disable Ghostery, all ads appear.

Debug Token:

jh7hzgjypg

Not sure what’s going on, but I’m at my parents and the internet provider is the same as my house. When I try to remote into my router - which I can usually do, I can only connect to my local router (my parents). I’m not sure if thats part of the problem… Does anyone have any suggestions on work arounds?


#2

Have you set Pi-hole as the DNS server on the router?


#3

Yes and I’m looking at the admin page now and Plex’s Metrics site has been blocked, but nothing is being blocked from my Mac. When I review my VPN’s IP, I’m showing that my IP is changing from my parents IP to my home IP via the VPN.

I’m also reviewing the details of my VPN connection and I’m seeing that my DNS is changing from 192.x.x.x to 8.8.8.8 and 8.8.4.4.

I’m guessing that the debug log hasn’t shown anything odd?


#4

Nothing odd in the debug log. Do you have IPv6 internet access? Also, check the DNS settings of the router and clients to see what they are getting.


#5

Just a try, disable IPv6 on your Mac.


#6

That’s part of the problem. I can’t connect to my home router since it’s the same IP as my parents router - even when I’m connected to the VPN. My public IP changes, but not my internal.

I also looked at my DNS on my Mac & it’s still showing my parents router’s DNS (which doesn’t have pi-hole) and not my home router, even if Tunnelblick is showing that the DNS as the google DNS.


#7

I just verified and it’s already disabled.


#8

Can you draw a network diagram of your situation, or explain it some more? Are you at your parents and need to modify your home setup, and are you trying to use Pi-hole over the VPN or just have it work LAN side?


#9

ISP at home is Bell Canada
ISP at my parent is Bell Canada

Public IP at my parents is .142 & when I connect to my VPN I’m showing .138.

I connect to my VPN in order to block all ads while I’m out of my house, plus access my Pi’s internal network for Plex, Sickrage and other things that I don’t have open to the public facing internet.

So, when I connect to my VPN, I’m getting all the appropriate access; however, when I log into pihole’s admin page. I’m not seeing any activity from my Mac remotely vs when I was connecting to it from work.

Not sure if this helps paint a picture, but I think it’s the best that I can describe.


#10

Ok, so when you check the web interface (only over VPN?) you don’t see any activity from the Mac, even though you had been using it via the VPN previously?


#11

That’s correct. I’m able to connect to the VPN and I’m able to see that my VPN is changing my DNS from my parents router to the pi-hole DNS - that I set on my router at home - but nothing is being blocked.

I’m not sure if it’s because we’re using the same ISP… I don’t understand quite enough of networking to see if it’s a gateway issue or something else. But I’m guessing that it’s not Pi-Hole related though.


#12

I have the same problem with my VPN connection with Fritzbox VPN (German). Pi Hole is working fine as long as i am at home using Lan or Wlan.
If I am using a VPN Connection there is no way to block any ads at all. I was not able to solve the problem so far.


#13

Huh, thanks! the only reason that I’m finding it odd is because it’s always worked perfectly fine before, except now that I’m at my parents for a bit, I’m noticing that it’s not working. But everywhere else, it’s perfectly fine.


#14

That is odd that it would only not work in that one location. It might be IP conflicts. So if you weren’t at your parents house, it would work?