Connecting via ethernet with Pi-Hole starter kit


Hope this is not a duplicate as I have tried searching many forums looking for a solution but not found anything on it.

I have a pihole starter kit from pi supply so comes all pre-loaded.

Trying to connect the pihole to my home hub 5 via ethernet just is not working as expected - it does not appear in the network list. I managed to update the pi as it will connect via wifi (gets assigned ip and can access internet) but I think maybe the home hub is reacting badly to the pi's request for a static IP as via ethernet it does not grant any internet access at all.

When connected via ethernet the pi appears only as 100mb/s on the lan 1 port it is connected to.

I can ping the pi and connect to the web interface via another pc on the network but the pi itself does not have any internet access.

I know I will have to disable dhcp on the home hub and run it off the pi in the end as the home hub won't let you choose your own dns, however I am reluctant to start trying that as there is clearly an issue with the internet access via the pi so I will not get any at all.

If I ping via the pi I get 'Temporary failure in name resolution.

If I try the web browser on the pi, fairly obvious no internet access is there (but is via wifi).

Is there a way of getting the pi just to accept an IP assigned by the router dhcp rather than demanding a static? seems like a good place to start as normally anything plugged in to the lan ports just works fine.

Have tried various cables etc that work with the other pc's. The ethernet lights are solid orange and flashing green on the pi port.

Any other ideas?

Apologies for the long post and also, as you can tell, I am not all that clued up on computers and networking in general.

Thanks for any help in advance.

Please send us the token generated by

pihole -d

or do it through the Web interface:


Thanks for replying, apologies for not doing the debug token initially - it is 5fsy19924a

I had to pull the ethernet cable from the pi to get it to upload the debug report, so that was generated with the pi connected via wifi (as soon as the ethernet cable is connected the pi loses all internet connection).

Looking at the web interface, should the gateway IP be the IP address of the router?

5fsy19924q ?

Sorry, maybe it was q and I made a typo copying.

Just run it again from the web interface and got pps43j96ik

This is now with the connection only over the ethernet, so I kind of solved that internet connectivity issue perhaps.

What I found is that in the dhcpcd.conf file it had a static domain name server entry - deleting that line and just leaving the static ip and static router lines in seems to have sorted the internet connectivity out.

On that bases, unless there is anything else wrong int he debug, I can probably look at turning off the dhcp server on the home hub, enabling it on the pi hole and restarting everything and should be good to go?

The Pi-Hole needs a static IP address, since DNS clients find it at that address and if the address changes, they can't find it. But, it can start with any address provided by the router. After it has an IP address, In the router make this a reserved (or static, or whatever your router calls it) IP address. Then run pihole -r, select reconfigure and use the static IP you just assigned.

Thanks, for your help.

What has happened is that when connecting it via wifi, it got assigned an IP, which I made 'static' in the router options. It then retained that IP when only connected via lan, but had no internet connectivity. That seems to have been an issue that maybe the pi was trying to use a non existent DNS server (no idea how that got set).

So I think I can set the IP now to be whatever, so as I understand it, to be safe I would be better off picking one outside of the home hubs dhcp range?

But then as I cannot change the DNS server setting on the home hub, I think I have to turn off the DHCP server on the home hub and run it on the pi?

OK so, kind of feel like I wasted some people's time sorry (jfb), but thankfully all seems to be up and running now and pihole is working :slight_smile:

So, for the benefit of anybody else that has the same problem with a Pi Supply pre loaded Pi Hole kit, these are the issues I ran in to and solutions:

  • Just plugging in the ethernet cable into the BT Home Hub 5 did not give the pihole any internet access, so running pihole -r was a bit of a car crash (couldn't access any lists to download etc).

  • when plugged in to the ethernet the home hub did not show any IP for the pi in the home network.

  • it could not see my wifi as it was running on channel 12. Changing that to channel 8, the pi could see it and I connected to the internet via wifi (with the ethernet cable unplugged). When connected via wifi it got an IP from the router via DHCP and in the home hub settings I ticked the 'yes' box for always use this IP (that seems to be the home hubs DHCP reservation equivalent).

  • when connected via wifi could run pihole -r and get it set up. Plugging in the ethernet cable still bummed out the internet access though.

  • using the file explorer on the rasberry pi (think you can use nano but for me was easier to edit it in a text pad), in the 'etc' folder edited the dhcpcd.conf file (after backing it up), leaving only the static ip_address line and the static routers line (deleted the domain_name_servers line, which seemed to be causing the trouble).

  • switched off the DHCP server on the home hub.

  • switched on the DHCP server on the pi hole via the admin interface

  • reboot everything

Hopefully helps somebody else, no doubt better ways to do these things if you know what you are doing.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.