Connect to IP adress with PI-hole

Expected Behaviour:

_[After configuring Pi-hole I wanted to go to my Admin portal by typing in the URL (Puffin broswer) http://IP adress/admin. Also the pi-hole admin URL didn't work.

This page isn't working

Error code:

What I Checked:

  1. Firewall didn't disable anything
  2. I could ping to any public server
  3. I could ping to my own IP adress
  4. Proxy servers settings are clear

~ $ pihole -r

gives error: Unable to update package cache. Please try sudo apt update. This leads to the same error

Actual Behaviour:

Connect to my IP adress and use my pihole admin portal

Debug Token:

When you connect to IP addresses, Pi-hole is not involved.

Your debug log shows your Pi-hole to be fully operational, with full IPv4 and IPv6 connectivity:

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] is on lo (
[✓] is on wlan0 (
[✓] is via a remote, public DNS server (

*** [ DIAGNOSING ]: Name resolution (IPv6) using a random blocked domain and a known ad-serving domain
[✓] is :: on lo (::1)
[✓] is :: on wlan0 (2a<redacted>8f)
[✓] is :: on wlan0 (fe80::<redacted>5a)
[✓] is 2a00:1450:400e:811::200e via a remote, public DNS server (2001:4860:4860::8888)

However, none of your clients has been using Pi-hole for DNS yet:

*** [ DIAGNOSING ]: contents of /var/log/pihole

-rw-r--r-- 1 pihole pihole 61K Jul 11 19:17 /var/log/pihole/FTL.log

   [2023-07-11 19:17:08.707 528M] Imported 0 queries from the long-term database
   [2023-07-11 19:17:08.708 528M]  -> Total DNS queries: 0
   [2023-07-11 19:17:08.708 528M]  -> Cached DNS queries: 0
   [2023-07-11 19:17:08.708 528M]  -> Forwarded DNS queries: 0
   [2023-07-11 19:17:08.708 528M]  -> Blocked DNS queries: 0
   [2023-07-11 19:17:08.708 528M]  -> Unknown DNS queries: 0
   [2023-07-11 19:17:08.708 528M]  -> Unique domains: 0
   [2023-07-11 19:17:08.708 528M]  -> Unique clients: 0
   [2023-07-11 19:17:08.708 528M]  -> Known forward destinations: 0

Your debug log also shows that your router is distributing its own IP address as DNS server:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   * Received 324 bytes from wlan0:
     Offered IP address:
     DHCP options:
      Message type: DHCPOFFER (2)
         --- end of options ---

You should have a read of Pi-hole's Post Install documentation.

Once you've configured your router and/or your clients accordingly, please share the results of the following commands on that client that runs the Puffin browser:

nslookup pi.hole

Thanks for the reply. But I am stuck at the following:

  • I follow the Post install documentation
  • Click next link configure your router to have DHCP clients use Pi-hole as their DNS server.
  • Then method 1 Setup says: Log into your router's configuration page and find the DHCP/DNS settings ..
  • I Try to reach routers configuration page by calling my routers IP adress via terminal ($ ip route | grep default) in my pi but and use it as input for the browser it gives the error again: net::ERR_CONNECTION_REFUSED
  • I try to change static domain_name_server in the etc/dhcpcd.conf file to the IP address of the device running Pi-hole., but it makes no difference. and browser gives still same error.
    _Also I have a raspberry pi 3A so no ethernet cable. The note at the previous mentioned setup link: Note: make sure you adjust this setting under your LAN settings and not the WAN. does not work for me right?

I am new to this and this is my first Pi project, so I am sorry for probably misunderstanding a lot.

Thanks in advance

I solved it. I used these instructions to set static IP adress How Do I Set a Static IP Address on Raspberry Pi?.

Thanks for the help

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.