Conditional forwarding with "daughter" router

I have the following network setup:
Fiber optics modem goes to the WAN socket on the ISP provided router.
To that router are connected via cable: a pi-hole, one desktop computer and a TP Deco mesh for wifi in the house).
The problem: In the pi-hole dashboard etc I see the desktop's IP, but all wifi devices are bunched under the mesh router's name.
I could not make the ISP router not register itself as a DNS provider (I set the DNS in the dhcp pool to only the pi-hole's ip, but is still gives itself as a secondary option).
So I need to set DNS manually in two devices: the desktop and the mesh router.
To do that on the mesh router I must use it in its "router mode", which comes with it's own DHCP server.
Final result is the following:
ISP router on 192.168.1.254
It has a network of 192.168.1.xxx
The mesh router sits on 192.168.1.70
It has its own network, 192.168.70.xxx, where it is 192.168.70.1

What settings should I use in the conditional forwarding section?
Thank you!

Expected Behaviour:

device names/ips show up in dashbpuard

Actual Behaviour:

all wifi devices are bunched under wifi router

Debug Token:

https://tricorder.pi-hole.net/3EYSROWC/

Conditional Forwarding won't help you here - it allows Pi-hole to assign hostnames with IP addresses.
But in your case, your mesh router is sending queries on behalf of its wifi clients, so its IP is the only one that Pi-hole will see.

Your issue is not with Pi-hole, but rather with networking.
Consequently, my advice can only be somewhat generic. You may improve chances for more specific advice when consulting other sources specialising in networking.

If your mesh router supports it, try to configure it to distribute your Pi-hole's IP address as local DNS server via DHCP (as opposed to configuring Pi-hole as your mesh's upstream DNS server).
If you already did this, your mesh router would NAT traffic between subnets.
In that case, try to enable EDNS(0) Client Subnet (ECS).
This may be labeled differently in your router, or not be supported at all.
Refer to your router's documentation for details.

Thank you.
I thought the problem was with the limitations of my equipment, but was hoping pi-hole might some clever solution :slight_smile:
Thanks again for your time and effort, and for the amazing job you ppl do here