Conditional forwarding still doesn't work

I'm running ph5.0 in docker using LXC container with ubuntu-xenial-1.
It's been running just fine, but Pi-hole isn't be able to determine the names of devices on my local network allthough the IP of my DHCP router and the domain name is set correctly.
An attempt ti dig gives the following result:

dig @192.168.0.1 <MyDeviceName>                                                                                                     
                                                                                                                                                         
; <<>> DiG 9.10.3-P4-Ubuntu <<>> @192.168.0.1 <MyDeviceName>   ; (1 server found)                                                                                                                                       
;; global options: +cmd                                                                                                                                  
;; Got answer:                                                                                                                                           
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 979                                                                                                 
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1                                                                                     
                                                                                                                                                         
;; OPT PSEUDOSECTION:                                                                                                                                    
; EDNS: version: 0, flags:; udp: 1280                                                                                                                    
;; QUESTION SECTION:                                                                                                                                     
;NAS327891.                     IN      A                                                                                                                
                                                                                                                                                         
;; AUTHORITY SECTION:                                                                                                                                    
.                       10800   IN      SOA     a.root-servers.net. nstld.verisign-grs.com. 2020052200 1800 900 604800 86400                             
                                                                                                                                                         
;; Query time: 5 msec                                                                                                                                    
;; SERVER: 192.168.0.1#53(192.168.0.1)              

The above output tells me that the connection to the DHCP router works ok, but still only IP address are displayed by PiHole.

dig +short @192.168.0.1 -x 192.168.0.10

Result in nothing at all.

Any help is appreciated.

Assuming that 192.168.0.1 is your router (and DHCP server), your dig results show that your router doesn't know names at all.
Of course, Conditional Forwarding will not help in such circumstances.

This may well be the case for some routers, e.g. Ubiquiti's Edge Routers will only provide local hostnames once configured to use dnsmasq, or some Microtiks may benefit from a script accepted as solution in Conditional Forwarding + Mikrotik?.

As any solution would be specific for the router model you are using, you should consider expanding your research to include your router's documentation and online support forums as well.

If Pi-hole is showing individual IP's, but not host names, then map the IPs to host names in either /etc/hosts on the Pi or using the Local DNS record feature of Pi-hole. With this information, Pi-hole can resolve the IP's to host names.

I run Apple routers and conditional forwarding has not been successful with them, so I use the hosts method and it works great.

1 Like