Conditional Forwarding not working

Please follow the below template, it will help us to help you!

Expected Behaviour:

Display the hostnames of computers

Actual Behaviour:

Just getting ip’s in place of hostnames.

Debug Token:

https://tricorder.pi-hole.net/c64uk0cau2

so i have a TP-link Archer c7 v5 router and i was having this problem and decided to just take the leap and flash it with openwrt. This should have resolved it. despite reverse lookups working just fine from the command line to both the router and the pihole. i’m a little confused as to where to look.

root@pihole1:/etc/pihole# nslookup -x 192.168.0.2 192.168.0.1
2.0.168.192.in-addr.arpa name = shark.lan.

root@pihole1:/etc/pihole# nslookup -x 192.168.0.2 192.168.0.3
2.0.168.192.in-addr.arpa name = shark.lan.

And below ?

nslookup -type=ptr 192.168.0.2

Make sure nameserver points to 127.0.0.1 where pihole-FTL is listening:

pi@noads:~ $ cat /etc/resolv.conf
nameserver 127.0.0.1

ok well the local resolver was set to google, i have reset it to localhost now.
but shouldn’t this setting be overridder by the ip address in the dns settings for conditional forwarding?

root@pihole1:~# nslookup -type=ptr 192.168.0.2
Server:         8.8.8.8
Address:        8.8.8.8#53

** server can't find 2.0.168.192.in-addr.arpa: NXDOMAIN

root@pihole1:~# nano /etc/resolv.conf
root@pihole1:~# nslookup -type=ptr 192.168.0.2
Server:         127.0.0.1
Address:        127.0.0.1#53

2.0.168.192.in-addr.arpa        name = shark.lan.

ok that was resolved after i restarted pihole-FTL. that’s still an odd bug. thank you very much for the help!

1 Like

dhcpcd5 should populate resolv.conf through resolvconf:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.