Changing port of WebUI

Hi, i am running pihole on my homebridge raspi4. Everything works fine, but i can't open the pihole webUI.
via IP -> homebridge webUI opens
via IP:80 -> homebridge webUI opens as well

homebridge is set to listen on port 8080.

The newest versions of both applications are installed. Both work fine - except for the problem above...

Thanks for your help.

Try with /admin added to the URL.

no change :frowning:

You probably have another web server running on your machine.

Please upload a debug log and post just the token URL that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

pihole -d

You are running nginx on port 80:

*** [ DIAGNOSING ]: Ports in use
[✗] tcp: is in use by nginx (
[✗] tcp:[::]:80 is in use by nginx (

You need to change nginx port to something else.

Alternatively you can configure nginx to run Pi-hole web interface or simply disable nginx.

Thx. nginx seems to be used by homebridge.

I changed the port to listen to. Now everything is fine.

Thank you for your help!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.