Can't use pi-hole DNS (or any DNS for that matter) on my Netgear C6300 router


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Router should be accepting my pi-hole DNS server

Actual Behaviour:

When I go to my router settings (Netgear Genie) to change the DNS server to Pi-hole’s DNS, it does not accept it:

So I click on “Use These DNS Servers” and then change the Primary IP to 198.168.0.33 (which is my RPi’s ip). I have the pi connected to the router/modem by ethernet, too. However, after hitting apply, it says:

I don’t think this is Pi-hole’s problem, though. Even when I try replacing the ip’s with 8.8.8.8 (primary) and 8.8.4.4 (secondary), it says, “Invalid IP address.” How should I proceed?

Debug Token:

u03mwuoe71


#2

Many routers do not let you specify DNS servers located on the LAN network that they host. The router enforces an upstream DNS provider that it can access via the WAN. Unfortunately in many cases these same routers have no option to change the DNS used on the local network.

You’re in luck though because your Netgear C6300 allows you to disable DHCP service (which is how DNS addresses are provided to the networks). On the C6300, the settings to do so are in “LAN Setup”, where you would have to uncheck “Use Gateway as DHCP server”.

Your Pi-Hole can instead serve as your network’s DHCP server, as well as DNS.

Check the FAQ for how to enable DHCP on your Pi-hole

And on your router, you can leave the DNS as “Get Automatically from ISP” as it will not be used by anything else on your network anyway once the Pi-hole takes over DHCP.


#3

#4

So I (1) unchecked “Use Gateway as DHCP server,” and then (2) enabled DHCP from within the Pi-hope web admin interface. However, this only disabled the internet. I’m not really sure how networking works, but is there any additional setup needed to make the modem/router “connect” the Pi-hole’s DHCP server so client devices can access it?


#5

This should not happen. Are your clients able to obtain an IP address when you re-connect them to your network?

Can you post a screenshot of your settings on the Pi-hole DHCP Settings page?


#6

This is a picture of the DHCP settings page:

And here is what I changed on my router:


#7

Un-check the router DHCP serving.
Also I think you need to expand the Pi’s DHCP address range.


#8

I did uncheck “Use Gateway as DHCP Server,” but will expanding the Pi’s DHCP range solve the problem? And what should I expand it to?


#9

I would expand it to include everything. Not sure how you can reserve static address (if needed, like for the router itself), but I am sure is possible.


#10

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.