Can't Browse To Websites Using Pihole, though Pihole Resolves DNS

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pihole setup on Windows initially with Docker, then Ubuntu VM on VMWare Workstation (current setup). Successfully resolves DNS. Should be able to browse to websites when NIC card manually is set to IP address of Pihole server.

Actual Behaviour:

I can resolve DNS with Pihole, for instance dns.google resolves to 8.8.8.8 and 8.8.4.4 using the IP address of my Pihole VM. I can ping the Pihole VM from my desktop. However when I manually update my NIC card settings on Pihole to utilize the Pihole as my DNS server, I cannot browse to any website. Admin panel does show hits coming in only from localhost client.

Any help is appreciated.

Debug Token:

1pwblualpu

Your debug log shows that Pi-Hole is working normally.

What OS is on the client you are using to set the NIC settings?

Hi Jfb

First off, sorry for the typos. That should state that when I update my NIC card settings on the client to utilize Pihole as the DNS server. I’m using a Windows client. If it is of any importance, the client I’m using to test is out is the same device that the VMWare workstation hosting Pihole is running on.

From the same PC, what is the ouput of this command from the command prompt:

ipconfig /all

Here it is

Ethernet 2 is the NIC adapter that connects to my cable modem and gets me out to the internet.

The NIC is at IP 0.8. The DNS server is on a different IP range (50.128). How can the NIC connect to the Pi-Hole at that IP? Do you have multiple VLANS and the Pi-Hole is on a bridged VLAN so the clients on other VLANS can find it?

What is the IP address of the Pi-Hole? If you generate a Pi-Hole debug log and upload it and post the token, we can look at the configuration.

Oh my… you are right! When I type “ping 192.168.50.128” on the command line, I was getting replies. I totally forgot that it’s probably sourcing that from the local NIC adapter… when I typed “ping 192.168.50.128 -S 192.168.0.8”… well guess what, I got transmit failures! You are right, there is no communication. I went ahead and changed the settings on my VM from NAT to Bridge. Got Pihole on an IP address of 192.168.0.9… and voila… now I’m seeing requests coming from my local client at 192.168.0.8 on the Dashboard!

I was thrown off by the successful ping of 192.168.50.128, thinking that since I could ping it from the command line it should work. Totally forgot about sourcing the ping from the correct NIC. Thank you so much sir! I realize now what is happening.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.